MobileSheets Forums

Full Version: Database Error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
In the process of making a backup to my PC, of changes made on the tablet, I have had an unexpected error. Actually, two of them;

1 - When connecting the tablet to the PC, using wifi, I see two ID's. ever seen this before.

2 - When I click on the (correct) ID, I get an error message concerning the database. When I cancel the message, a disconnect occurs. Never seen this before, either.

Attached two screengrabs showing these errors.

The tablet appears to be working correctly and nothing has been corrupted, as far as displaying charts, setlists, etc.

Not sure hwere I go from here?
Wow Graeme, that is really, really weird. I have never seen either of those errors. If I had to guess, I think there must be an incompatibility between the companion app and the tablet. I think something is in the database that the tablet can handle, but the companion app can't... but that's not what the error message is saying. It sounds more like the database is being corrupted when it's transferred, or the companion app thinks it's corrupted.

If this problem is repeatable, then I could really use your help by either sending me a library backup or just the exported database (Utility->Advanced->Export Database). I should be able to import your database without the PDFs, then connect the companion and debug the code to see what is going on, so I think that should be the first step. If you can, please email the file to Thanks!

Thanks for the quick response.

Nothing has changed here, I'm using the same (latest) versions of both MS and Companion that have been here since the last update of both softwares. One thing I haven't tried yet - but I'll have a go sometime today - is to see what happens when I try and link to my laptop, rather than the desktop.

I'm not in panic mode (yet) as the tablet is working fine and still useable. However, the inability to maintain a link between the tablet and the PC means I can neither make a backup nor restore an earlier one. Obviously, this is not going to be a good thing in the longer run.

I'm out for most of today, but I'll send the file to you later this evening.

Tried with the laptop - and it seems to work OK. At least, I made a backup and could extract the result into Companion. Wasn't brave enough to try a restore - I need the pad tomorrow!

Hmmmm... on that basis, I'm tending towards some sort of file corruption on the desktop. I'll try a re-install of Companion and if necessary a reboot (hasn't been off for weeks). I'll hold off bogging you down with files until I've had a further crack at it myself.