MobileSheets Forums

Full Version: Wrong chart!!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Mike, there seems to be a major problem with the latest release of Companion [2.0.7]!

I have just done a backup from MSP - went well. I then tried to extract one file from the list as I wanted to see if it extracted the audio - It didn't.

However, that was not the main problem. It is associating the wrong chart with the filename. I extracted 'The Chicken' and when I looked in the directory this created, the PDF file, although it had the right name actually contained the PDF for 'The Christmas Song' .

I checked back on the tablet and that does display the right file. I did a bit more digging around and it seems that each PDF I extracted from the backup file, although correctly named, contained the PDF for the next chart on the main library list.

I then loaded an earlier backup file (done four days ago, with the last Companion version) and that extracts properly, so I believe the problem has to lie with the current release of Companion.

What I haven't tried - and I'm not about to, either - is to import the latest backup back into MSP. I have a feeling that everything is going to be wrong Wink and I don't want to lose the fairly extensive changes I have just made, which prompted me to make the backup in the first place.
In the last update, I was trying to address a problem with unchecking the "Backup audio" option, namely that I was stripping all audio from the database in the backup file. After reflecting on this, I could see situations where people don't want to back up their audio files, but want to leave the audio file information intact in the backup database. So I changed the backup to remove the audio files but leave the database information.

The problem you just encountered - did you experience that with the "Backup Audio" option on or off?
Graeme - have you used any placeholders in your library, or songs with blank pages? The companion extraction dialog currently has a bug in that it doesn't properly handle those.

The nature of my changes are so small that the only possible scenario I can see where my current implementation could go wrong is if you had an audio file associated with a song that has a blank path (meaning it's completely invalid). Do you happen to know if any songs in your library have audio associated with them, but the audio is blank? I have a fix in place for this now regardless, but I'm just looking for a way to explain what you are seeing.

Taking your points in order;

1 - I always have 'Backup Audio' on, if only in the hope that one day it will do so and allow me to extract the audio using the PC. Also, I like to keep the audio files off the tablet, other than the ones that are actually associated with music and it seems the best way to do that is to have any audio in the same directory as the chart.

2 - I do have one placeholder in one setlist - and I only added it today. This is the first time I have ever used blank page, so maybe that's the cause of the problem. I'll try removing it and doing another backup.

3 - TTBOMK, there are no missing audio files/blank paths, etc. I can't be absolutely certain about this as I have some 2,000 charts. I only have audio files associated with a small percentage of these (maybe 200/250) and there is no easy way to check all of them, other than trawling through the whole list, one by one. You may recall I asked about marking charts in Companion that had an associated audio file - this was one of the reasons I asked the question.

I removed the one placeholder that I had added, to just the one setlist, and did a new backup. All the charts are now correct.

I'd still like to be able to extract the audio files as well Smile .
Excellent! That issue will be fixed in the next companion update.

I'll try to add those audio enhancements as soon as I can. There are so many things on the TODO list that I almost don't know where to begin...
Thanks Mike - I knew you could do it Wink .

No panic here for the audio thing, plenty of other grollies to deal with first.
I hate to say this - but it still isn't working.

I have downloaded the latest versions of both MSPro and Companion.

In MSP, I added three placeholders. One with no text and two with just a couple of lines of text. All three were within the same setlist

I then tried a backup. This seemed to be working, until I noticed that it seemed to have stalled at 21% on one of the placeholders (titled ENCORE NUMBERS). Actually, this happens to be the blank page, but I don't know if that has any significance. As far as I could see, it was the first placeholder the backup encountered, maybe that has more significance.

I say stalled because, although the 21% stayed the same, it was busy counting down a lot of KB - see screenshot. I guess the count was actually the size of the remaining backup (the total is around 1.5 GB). While this was going on, the tablet was behaving as I would normally expect during a backup, busily reporting a successful transfer of each file.

Finally, the countdown stopped, just short of zero (see screenshot) and the tablet reported the backup was complete (another screenshot).

Nothing else happened for a long time, so I cancelled the Companion screen and looked to see what happened to the backup file. Another screenshot shows this is, in fact, empty.

FYI, this was using my P900.
Sorry Graeme - I was so focused on making sure the restore worked that I missed some changes on the backup side. I just pushed out 2.0.9 for the companion that will fix this issue. Hopefully I can get to a stable point here where I can take a little longer between updates so I can allow for more thorough testing. I've been rushing a few of these updates due to the severity of the problems.

Thanks Mike - seems to be OK now. I haven't tried a restore yet, be doing that later this evening, but all the files seem to correct when I use the extract command.

One minor thing I did notice was that the placeholder pages, although showing in the library don't extract - not sure if this is intentional or what?
Just did a restore - everything now works as expected. Many thanks for the fix