MobileSheets Forums

Full Version: Can't add new songs
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

I am dealing with what seems to be a slightly corrupted backup file / database, but perhaps there is also a bug somewhere.

Whenever I try to add a new song it displays this message in the preview section:
"File /storage/emulated/0/Download/I Want To Know You.cho does not exist"

This is the name of a chordpro song I added into the database not long after MobilesheetsPro was released, and this problem has been around since then.
There is nothing in the file list, and whenever I try to add a file it tells me I cannot mix text files with other file types.

I have tried clearing app data completely and restoring a backup, but the problem persists after restore (not before restore though).
I also tried deleting the song with the same name and restoring from a backup of that, but no difference.

Note, it is possible to add songs when opening files with MSP from a file manager.

Is there any way to fix this without rebuilding my database from scratch? (I have over 200 songs)

Does this song actually exist? If not can you create it and see it it appears in the list and can be removed?
That is really bizarre. If you force close MobileSheetsPro (exit out, hit recent apps, swipe MS Pro off the list), then reload it, then tap on the "Add" button with the Recent or Songs tab selected, you see that message? Do you also encounter errors if you go to Import->Local File? If you edit an existing song, what happens?
If I create the file that it is complaining about, it shows up in the preview window, but it is not listed in the file list and I haven't found any way to remove it. 
Yes it still happens after force closing the app, but import local file works without any trouble.
Editing an existing file works as expected and shows the file(s) in the file list as normal. I can remove all files and add a new file without trouble while editing a song, but not when creating a new song.
Hi Mike,
Is the .msb file some form of archive that I could extract and see if I can find the error?
I tried opening it with 7zip, but that didn't work.
Yes, it is 'some form of archive', home-brewn by Mike Wink.
I have some tools on GitHub that process MSB files which may be helpful.

So I am still having trouble with "ghost files" when trying to create a new song. Now there are two of them showing up and preventing me from adding any other files.
Have tried using Johan's tools, but can't seem to find anything.
I think there must be something weird in the database file, which is attached in case anyone is able to have a look at it.

Everything works fine if I clear the library, but as soon as I restore my backup, the problem is back again.

Any ideas?

How are the ghost files preventing you from adding new songs?
When I try to select a source (e.g. folder, image, dropbox) a message pops up saying that "You cannot mix text files with other file types". But there is no way to remove the text file that it thinks is there.
Just to clarify, the file list shown in the song editor shows no files whatsoever, yet when you try to import a file you see that error message? What types of files are you trying to import?
Yes, that is correct.
No files are shown in the file list at all, yet I am still getting that message (but two files are shown in the preview area).
I am trying to import pdfs mainly.
Now I'm confused... you say no files are shown in the file list, but two files are shown in the preview area. When I say the file list, I mean that preview area on the files tab where you can tap on each file to select them and preview them. If you see two files there, what types of files are those? Is the last file you tried to import when you received that error a PDF? Or was it a text file? Are you trying to add lots of files to one song instead of creating one song per file?
Ok, I'll try to explain more clearly. See also screenshot attached.
So this is what I do...
  • Go to songs tab.
  • Tap "NEW" in the action bar (screenshot taken here)
  • On the "Files" tab:
  • Under "Files:" there are no songs listed
  • However it thinks that I have already loaded two songs, which are shown in the preview window on the "Files" tab.
    One of these is a PDF and the other is a TXT file.
  • When I tap on the folder icon, it pops up with the warning "You cannot mix text tiles with other file types."
There is no way to remove the files that are shown in the bottom half of the screen, because they are not shown in the top half of the screen.
And because one of the files in the bottom half is a txt file, it won't let me add any more files to the top half.

I am only trying to create one song per file, but I can't even choose one file for the new song.
That is so bizarre... Can you try something for me - go to Display Settings->Render Preference, and change from quality to speed to see if it makes any difference (if a PDF was cached for some reason, this could fix it).

I'm going to analyze all of my code to see if I can come up with a scenario in which the behavior you are witnessing would occur. I'm definitely at a loss right now...

Pages: 1 2