MobileSheets Forums

Full Version: 1.4.4 Cannot display large jpg
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
1.4.3 and 1.4.4 is not able to display a 4.3MB 3045x4059 jpg on my tablet. After a fairly long black page + spinner I get "Unable to load page 1 for file ....".
Is the image too big?
I haven't tried a file that big in awhile, but I'm not sure why it would cause any issues as I scale the image down to fit the screen anyways. The only possibility is that one of the Android API calls is failing. I'll have to get my hands on an image that big for testing (or if you can email it to me at then I will use that one).

So I'm finally back home and I had a chance to test out the file you provided. Unfortunately, it works just fine for me on my Galaxy Note Pro and my Nexus 10. Did you crop the file or perform any other modifications?

No, I just made a picture of a sheet of music using my camera (not the tablet) and uploaded it to the tablet.
Could it be a memory problem? The tablet has only 2GB RAM.
Even if the image was rendered full size with 4 bytes per pixel, that would still only use 49.4 MB, which shouldn't be large enough to cause your device to run out of memory (and the image should be rendered to fit the screen and only use 2 bytes per pixel). I'm going to have to do additional testing with an emulator matching your device configuration to see if that makes a difference.
Most image renderers I know load the whole image (in particular when it's a compressed image) before producing the scaled down image.
But even at 24 bits/pixel, the resultant size should not exceed 60MB...
The image also loads on an emulator running 4.4.4 with 2GB of RAM. I'm completely puzzled by this now as it has worked on everything I've tried. I'm not sure where to go from here....
Might it be the OS?
This is very puzzling...
Most likely someging went wrong while importing, causing some kind of corruption somewhere (pretty vague, yes I know Smile).
But I can import a new copy of the same file and that works. So let's consider this solved.

Note about the file dialog: When editing a song, in the Files tab, press the "image" icon.
I get some kind of file chooser.
However, whatever image I select, I always get an error similar to this.
When I select one of the tools at the left, and select a file, it works okay.

Is this how it should work?
The file chooser on my Galaxy Note Pro doesn't have a SD card option like yours does. If I pick a file from "Images" or any one of the other categories on my device, it works just fine. I tested this on several devices and all worked okay. Do you encounter the same error if you pick from Images or a different app in the bottom section?

Probably an OS peculiarity, then. Android keeps surprising me.
Choosing images like you indicated works flawlessly.

How do you run MSPro under an emulator? I always get stuck since (my) emulators do not emulate google play+services.
Google recently released new images that have Google Play + Services. I've never actually needed these though for the basic tests I'm running in the emulator. I just push files to the emulator and import those files to run the tests. Likewise, I can also push backup files to the emulator for more involved tests.

It's the license check that fails and becomes a nuisance.