MobileSheets Forums

Full Version: Save & Archive in SD Card
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
it's my first thread.
How can i set my SD card like principal storaeg location? In my setting (when i click SD button) it doesn't find my card.
Please, help me.
This somewhat depends on what version of the OS you are running (and what individual tablet suppliers have allowed you to access). Some versions don't allow writing to the external card at all - although there are work-arounds to this, which you will find documented on this forum. Other versions insist on only writing to a specific directory, you'll find details about this as well.

So, the first question is what tablet and OS do you have?
(05-01-2016, 04:10 AM)GraemeJ Wrote: [ -> ]This somewhat depends on what version of the OS you are running (and what individual tablet suppliers have allowed you to access).   Some versions  don't allow writing to the external card at all - although there are work-arounds to this, which you will find documented on this forum.  Other versions insist on only writing to a specific directory, you'll find details about this as well.

So, the first question is what tablet and OS do you have?

I have the new Tablet Hannspree Titan 2, with Android Lollipop.
Which are the workarounds?
Thanks you!
Please, help me!
Sorry for not responding banturi - lost track of this thread. Can you manually select the path to the external sd card? In the dialog used to set your storage location, tap the folder icon, then try to find the external SD card which will probably be something like /storage/mnt/extSdCard, or /storage/mnt/sdcard1. If you can't find it, let me know what folders you see under the /storage/mnt directory.

The work-around I used is documented here -

This was for Android 4.4.1, later versions only allow writing to a specific directory associated with the app in question. The whole thing is a bit of a can of worms as Google try to control what the end-user can actually do, in the name of 'security'.  

On another tablet, I had to physically make the correct directory on the external card (on my PC) before I could get MSP to see it.
I've seen this on a couple threads and can't seem to figure it out myself. I'm running 4.4.4 and am under the impression that MSP should be able to write to a specific directory, but I'm having no luck.
Here is the error I'm getting:

"The directory /mnt/external_sd/Android/data/com.zubersoft.mobilesheetspro/files is read-only. Please select a different directory that can be written to. If the path is on an external SD card, use the SD card button to find a writable path."

Well, if I click the SD card button this is the path it gives me, which I am pretty sure is internal storage. Correct me if I'm wrong...but it gives me:

Am I doing something wrong? Or do I give up the idea that this 32GB card will help me?
If you tap the SD card button multiple times, it should cycle through any sd cards and internal storage. Does it change at all if you hit it twice? If not, that means that MobileSheetsPro is not recognizing the external SD card as valid storage for the application, which is odd. I'm assuming you created the directories listed above so that you could select that path, right? Please try something for me - access the external SD card through the /Storage folder instead of /mnt and let me know if this has any impact as far as permissions go. This should be something like /Storage/extSdCard or /Storage/sdcard1.

Just tried tapping multiple times - no other options. Yes, I created that path manually via my system explorer outside of MSP.

If I go to /storage, I see only /emulated and /sdcard0, which I assume is the internal SD storage.
/emulated has subdirectories of /0 and /legacy.

All three of /storage/emulated/0, /storage/emulated/legacy, and /storage/sdcard0 appear to have identical substructures (I don't really understand why, I haven't played around with Android devices enough to figure it out.)

If I go to my system settings and pick storage, I can see that the card is mounted (28.96 GB available), but I don't see any options for permissions.

Am I going to have to root my device to make this work?
It sounds like your tablet is handling the SD card in quite a different manner than other 4.4+ tablets I've tested. I'm not sure why MobileSheets is not able to write to the directory you specified, as that works on other tablets I've tested. I want you to check something for me. If you use a file browser to find those folders you created, and view the properties on them, you should be able to see what kind of permissions the folders were created with. Verify that they were made readable and writeable.

If we can't figure this out, then you probably will have to root your device if you want to use the external SD card. The other option would be for you to manage the files yourself on the external SD card, and disable the file management in MS Pro. This should work fine as long as you don't need to import files off of Dropbox or Google Drive.

I inserted the card into my PC and looked at the file structure..."properties" shows the read-only box as blacked out (not checked, but a black square inside the box. Clicking twice turns it into a check). If I click that option to clear it out, and hit apply/close, when I reopen the properties it shows the exact same thing as before.
Support for my tablet (Southern Telecom) was not very helpful...basically he said that the expandable storage can only be used for storing videos and pictures...see conversation below.

info: at 13:06:47
Please wait for a site operator to respond.
info: at 13:06:49
You are now chatting with 'Joseph'
info: at 13:06:49
Your Issue ID for this chat is LTK1115901032225X
Joseph: at 13:06:56
Hi Alex, thank you for contacting Southern Telecom. How may I help you today?
Alex: at 13:08:01
I have a Smartab ST13
Alex: at 13:08:17
I bought an SD card but am unable to get apps to recognize it
Alex: at 13:08:40
Is there any way to make the SD card writeable in Android 4.4.4?
Joseph: at 13:08:48
I understand your concern, but as SD card can be only used to play media files on your device.
Joseph: at 13:09:03
Games or apps won't be loaded on the SD card.
Alex: at 13:10:17
I'm trying to let an app manage a library of pdf files of music
Alex: at 13:10:41
But the app says the card is read only.
Joseph: at 13:11:10
You can try transferring or managing the files on SD card using computer.
Joseph: at 13:12:53
Or else, you can use the file manager to manage the files.
Alex: at 13:14:28
Unfortunately that doesn't work with the app I am using to read sheet music. The app has to have
read­write access to the files.
Joseph: at 13:15:00
Okay! In this case, you can move the files to your internal storage and try accessing it.
Alex: at 13:16:18
That defeats the purpose of having an SD card...
Alex: at 13:16:28
I need more space on the tablet.
Joseph: at 13:16:25
In SD card you can load movies, songs and all other media stuff to use it on your device.
Joseph: at 13:17:01
Some apps won't support the files to have on SD card.
Joseph: at 13:19:30
Not to rush you, Are we connected?
Alex: at 13:20:37
Regarding the app I am using, the developer says that in android 4.4.4, I should be able to create a
specific directory /mnt/external_sd/Android/data/com.zubersoft.mobilesheetspro/files and this
directory should be detected by the tablet as writable for this app. He says it works on other tablets
with 4.4.4 and says if it doesn't work for me, it's an issue with my tablet model.
Alex: at 13:21:11
It's apparently worked on all other brands with the same OS.
Joseph: at 13:22:17
I understand, this device is compatible only to write on internal storage.
Alex: at 13:23:38
If that's the case, then the packaging and documentation is very misleading.
Alex: at 13:24:12
"Expandable storage" to me implies read and write permissions.
Joseph: at 13:23:20
On SD card, we cannot really have access to write over SD card and you can load the media files.
Joseph: at 13:24:10
Yes, you can do that but not for apps but for media files.
Alex: at 13:25:30
Unfortunately this is not used as a media device. I'm using it as a music reader due to the large
Alex: at 13:26:02
Is there a way to safely root this tablet to edit the permissions files
Alex: at 13:26:14
I'm not under warranty but don't want to brick it.
Joseph: at 13:26:59
We're not sure about the rooting process and we generally do not recommend you to root, cause that
leads to brick the device.
Joseph: at 13:27:41
You can have them on internal storage and use SD card for media files.
Joseph: at 13:28:15
If the internal storage is full, please try to uninstall few apps to clean up some space.
Alex: at 13:30:23
Unfortunately that is not an option. I've already disabled most of the bloatware to free up enough
space just to run the few apps I have installed. And I don't have any "media" to move to the SD card
I don't think you will be able to see the read/write permissions on the folders through Windows. I was suggesting using something like ES File Explorer which will tell you what the Android file system is reporting. In any case, that discussion does lead me to believe that the flavor of Android 4.4 on that device is not set up to allow applications to write to the external SD card. I would suggest rooting if you can.

I downloaded ES file explorer and checked - these folders I created are in fact readable and writable according to the properties.

So...then the next question (for whoever, not just Mike) would be, what is the safest way to root a device - I've never done it before and don't want to brick it on my first try.
It's a Smartab (model ST13-16) made by Southern Telecom.
UPDATE - I did end up successfully rooting and have managed to get the SD card to work as a storage location (and it appears that Vudu has now discovered it as well, which was really why I wanted more storage I can download movies to the card and not worry about losing space for my music!)

Thanks for your help.
Pages: 1 2