MobileSheets Forums

Full Version: Cannot access SD card
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have two folks in my club that have new Visual Land 13.3 inch tablets running Android 5.1.1. When trying to download files from an SD card i get the error message "Cannot Access SD card". I can go to explore and see that the card is there and it recognizes the PDF files just fine. Anyone having this trouble and can you tell me what to do to fix it? Huh
I was a little slow in responding to your email - what is the path to the external SD card that you are using? What app are you using to explore the external SD card? We need to identify whether other non-stock apps can access files on the external SD card. Can you install another PDF reader like Adobe Reader, and see if it can read files off the external SD card? I've seen reports of other tablets that provided no read-access to external SD cards, so I'm hoping this is not the case.

Mike, I was using the explorer app to explore the SD card. This tablet does not seem to have one that I am used to such as My Files. This app has a bar at the top with the following selections: Home, Level Up, Multi, Editor, NewFolder, back and next. under that is the following: Internal Memory, SD card, USB storage. When I select SD card I get the contents of the card correctly. I had a live chat with the manufacturers support and told them what happened and they of course said it must be MSPro that has a problem.
I loaded Adobe Reader and when I opened it and selected local I got a large list of PDF song files with a path as follows: Storage/emulated/0/android/data/com.adobe.reader/files/Downloads. I have no idea where this came from. These are files that are on the SD card but there are several folder on the card and none of them show up here. Also, I tried loading the tablet from the Companion. It worked to some extent but failed to load all of the songs. There are over 1700 PDF song files in the library and only about 1560 were loaded. I am sure it has something to do with the tablet system. I tried using the USB port also and it shows up ok in Explorer but MSP says cannot access USB. Sometimes I hate computers.
In desperation I uninstalled MSP and reinstalled it. Still no luck with the card. Tried the companion again without much luck. Downloaded 23 files and then a few more but mostly now I get an error message after disconnecting from the companion. Unable to create file for transfer/ and it goes off before I can read it. I looked again in the explorer and there are files there but they are in a folder titled; Internal Memory/android/data/com.zubersoft.mobilesheetspro/files. MSP is set to send files to /storage/emulated/0/Android/data/com.zubersoft.mobilesheetspro/files.
When I go to the "Explorer" on the tablet and use the following path: Internal Memory/Android/data/com.zubersoft.mobilesheetspro/files I get a listing of song files that are from my computer. If I try to use this path in MSP I go to settings, Storage, Set the MobileSheets Storage Location and click on the folder there is no path available like what is on the tablet. What comes up is the default location and going all the way back to the root there is no choic of Internal Memory. I do not have a clue how the files got into the folder on the tablet. Any ideas? Also I could find no way to access the SD card using Adobe Reader. I could find no way to select the card.
I finally checked out Adobe on my Samsung tablet and see now how it works. It automatically finds all the PDF files i guess. On my Galaxy, it located the files that are in the MSP folder and it also found the external SD card. On the Visual Land tablet it did not find the external SD card. Hope that helps.
In an attempt to "improve" security, the later Android versions will only allow writing to the external card under very specific (and app-related) conditions. From the point of view of an idiot user, this might (but only might) have some advantages, for anyone even mildly computer literate it's a real PITA.

I've just purchased a new tablet (for use as a backup) and ot runs under Lollipop 5.1. Needless to say, I ran into exactly the same problem of writing to the external card. On a previous tablet, I solved the problem by rooting it and then changing the permissions to allow writing to the external card. On this tablet (an eSTAR GRAND HD Quad-Core 4G) I have yet to find a way to root it. All the methods I know of have failed and I get a string of reports saying the device can not be rooted.

However, I have found a way to write to the external card, one which may work for you as well.

Load the external on your PC and then, using a file managing tool, create a directory and sub-directories as follows;


Put the card back into your tablet and open MSP Settings. In the Storage section, tick 'Let MobileSheets Manage My Files' and then cursor down to 'set the MobileSheets Storage Location' and tap on it. In the menu that opens, tap on the INTERNAL icon (that's the left one that looks like a folder) this will open the Android file manager. Now, tap on the < symbol at the top left corner, until you get back to the 'root' directory. From there, you can set up a file path to the external card. It will look something like:

Root/storage/extSdCard [or whatever your tablet calls it]/Android/data/com.zubersoft.mobilesheetspro/files

Once you have set the path, tap on 'OK' (centre bottom of screen) and check that the correct path shows in MSP. Click on 'OK' and you're done and the files should now write to the external card.

Have fun! Let me know how it goes.
Thanks for the info but my problem is with getting information from the SD card not writing to it. I have already got information on writing to the SD card on tablets with the newer android system. The problem I have is with a particular tablet make that seems to have made the storage path different than that of the standard system.

Based upon your description, I believe that particular tablet does not allow third party apps to access the external SD card at all. You said you spoke with the manufacturer, but they obviously didn't know what they were talking about. You can go back to them now (if you want) and explain that no app on your tablet has access to the external SD card, so this must be a configuration issue on their end. They most likely have not set up the permissions for the external SD card correctly. This is not the first time I've seen this unfortunately - some of the off-brand tablets seem to experience this problem due to the manufacturers not setting up the OS correctly.

It might still be a good idea to see if an app like ES File Explorer can access the external SD card. If not, then I am confident in what I stated above.

Thanks for all of your help. I installed ES Explorer on the tablet and you are correct. I cannot access the external card. I am not sure what I will do about it but I don't think I want to get into a discussion with the manufacturer. 
(07-24-2016, 05:01 AM)larrydgriffin Wrote: [ -> ]Graeme,
Thanks for the info but my problem is with getting information from the SD card not writing to it. I have already got information on writing to the SD card on tablets with the newer android system. The problem I have is with a particular tablet make that seems to have made the storage path different than that of the standard system.

In an earlier post you said " MSP is set to send files to /storage/emulated/0/Android/data/com.zubersoft.mobilesheetspro/files."  To me it would seem that you are not writing the files to the external card, this command indicates they are going to the internal storage area - which would explain a lot of things, or at  least the fact that you can't load all of your charts for lack of internal space.*

* I just had a quick look at the specs for this tablet. It has 32 Gb of internal memory, so I am really surprised you seem to be running out of space. What sort of charts are you loading?

Could I ask you to at least try the procedure I outlined and see if it hellps at all. Until you can get your charts on the external card, you will never get it to work as you want.

If Mike is right and it proves impossible to access the external card in any way (which would seem a very strange thing) then I'd take it back to the place you bought it from and tell them it is unfit for purpose!  Ask them to change it for a model that does do what everyone would expect of a tablet.
(07-24-2016, 03:22 PM)Zuberman Wrote: [ -> ]It might still be a good idea to see if an app like ES File Explorer

ES Explorer has been disgraced. I'd suggest to use Solid Explorer instead.
Thanks for the heads up, I will give it a try.