MobileSheets Forums

Full Version: Stylus not working correctly
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
[attachment=738]I'm new to using MobileSheets. I've recently purchased an HP Spectre 360 laptop and HP Active Stylus to begin digitizing all my music.
When I'm in the annotation editor, I cannot get the stylus to write on the screen as it's supposed to.  This laptop is such that I'm supposed to be able to rest the palm of my hand on the screen while writing.  I have the stylus mode enabled and marked the "show annotations" selection.  When I attempt to use the stylus the marks I make only stay visible while the stylus is touching the screen.  Very small segments of the marks are visible after lifting the stylus from the screen.  After I save and exit that window the marks become more prominent, but nothing close to what was intended.  It's also not in the same location as I wrote it.   I've attached a screenshot of the saved document.  I tried to "X" out the first ending in blue.  You will see on the attachment where it actually ends up. Does anyone know what's going on?  I could not find anything in the forum covering this problem.  Confused

PS.  The stylus works fine outside of MobileSheets.

Thanks in advance.
That's really weird. I have a couple of questions for you:

1) Does the stylus work correctly if you disable stylus mode and write with the stylus without placing your hand on the device?
2) Is this a PDF file you are working or a PNG file?
3) Are you zooming in while annotating or just writing the marks at the default zoom level?

Hi Mike,

1. The stylus doesn't work correctly whether in stylus mode or disabling the stylus mode. Doesn't matter if my hand rests on the screen or not. The marks made do not show until after I exit out of that song and go back in. Even after saving right after making the edit. So I have no good idea of where the marks are actually going. Trying to write words is impossible. It's like writing blind.
2. The attachment above is an imported PNG file. I tried on a PDF import and the stylus acts the same on the PDF as it does on the PNG file. The first two attempts the annotations ended up where they were supposed to after exiting the song and going back in. Then the annotations started showing up after I lifted the stylus but were about an inch or two lower than intended. I have no idea what changed.
3. I tried annotating in both a zoom screen and the default zoom level. Made no difference.

If you do what you describe but with your bare finger and it works, it means you have a capacitive touch screen like mine, and whatever you will do with an active stylus pen will just not work, because it won't be a resistive digitizer...
That's why I end up doing all my editing in Lanscape Mode for a larger covering, then I do all my editing with fingers before I turn it back to Portrait Mode for live reading and more music viewing.
But I might be wrong... like I was when I bought this Dell Inspiron 2 in 1 convertible laptop for its large 17,3'' touch screen before I found out after buying different stylus etc that it would just never work any better than with bare fingers!
But I got used to and found a suitable way to do what I need.
Good luck!
I did mean to ask that as well - does annotating with your finger work correctly?
With the stylus mode off, and trying to write with my finger, it acts the same. The lines shows until I lift my finger and then shifts down and to the right about 2 inches. It's really weird.
Everything else works fine, the highlighting and stamps etc. I'm at a loss.
If you tap the circle at the top left, and tap on the grid settings, is "Snap to Grid" enabled?
The "snap to grid" was not checked, but is now. It does not make a difference. This is while editing using my finger and not the stylus.

I did notice while trying this that the first line I make is visible on the editing screen (although an inch or so below where it was intended, with the grid snapped). As soon as I start to make another mark that first line disappears and all notations then do not show until I exit out of the editing screen. And then as mentioned, everything is lower in position than it should be. Don't know if that helps diagnose anything or not, just wanted to mention it in case.

If you search in Windows 10 for "Make text and other items larger or smaller" (which takes you to the display settings for Windows), what do you have the percentage set to for "Change the size of text, apps and other items"? Did you increase this value by chance? Are you using anything else that is magnifying the screen? I'm just trying to find a reason why the touch events would be located in a different spot than where the annotations are being shown.
Good call. I did have the percentage set at 125% to accommodate QuickBooks appearing the way it should. After I reset that setting to 100% the notations made now show where they are intended, although not until I exit that screen first.
We're getting closer.

For what it's worth I have the evaluation version of MusicReader 4.0 PDF installed on my PC and decided to try to make annotations in that program to see if the same problem happens there too. It doesn't. Notations show up right away and where they should be.
I still like Mobile Sheets better. Sure hope we can figure this out.
Now that we've located the problem, I can work on reproducing it and creating a fix. I'm probably just not accounting for the screen scaling factor appropriately somewhere in the code (or the way I'm retrieving it doesn't account for that setting in Windows). It's still weird that you aren't seeing your annotations until you leave the editor - that issue still doesn't make sense to me. You are using version 1.7.5 of MobileSheets right? Did you crop the song you are annotating? Does removing the cropping have any impact on being able to see the annotations in the editor? What display mode and page scaling mode are you using when viewing the song?

MusicReader 4.0 isn't a Windows Store app (to my knowledge). Does it even respond to that percentage slider? Or does its size stay fixed?

Exactly the same problem I had... using Windows in anything else than 100% makes problem in MS!
But we do want to be able to use that, I think...
Yes I am using version 1.7.5
I have cropped most of the songs. I reset the cropping on one of the songs to its original view and attempted some annotations and continued to have the same problem. I do have the resolution set back to 100% so at least the marks end up where they're supposed to when I exit the editor window.
Not quite sure what you're asking for regarding the display modes. In the main settings page under the display tab I have Full Screen Mode turned on. I tried turning it off, but it made no changes.
I have it set to view 2 full pages at once. If that's what you're asking.

I happened to take the laptop to BestBuy where I bought it to see if there was something I wasn't explaining well enough. The techs there could not figure it out either. They said it would have to be fixed in the coding somehow so the annotations would show in the editor screen. They also said they couldn't find any setting options specifically for the stylus itself.

I'm testing on my laptop (not my usual testing device), and I'm seeing some problems with the annotations editing. I can see the annotations as I'm drawing, and then they are disappearing after I release the mouse. They are also being offset most likely due to the scaling factor in Windows. I'll make sure I get everything working properly on my laptop, which will hopefully fix all the issues you are experiencing as well.
It looks like the problems stem from using the "Smooth" setting. If you set this to "None" in the pen tool settings window, you shouldn't encounter any issues (assuming the problems you are seeing match what I'm seeing). I'll fix the smooth setting logic for the next update.
Pages: 1 2