MobileSheets Forums

Full Version: [SOLVED] [2.1.2] Malfunction
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Suddenly MSPro started malfunctioning. Everything behaves normally until I try to display a song (ChordPro, PDF, image). Then MSPro freezes (reboot needed!) or crashes.

This happens on two distinct tablets (Android 7.0 and 7.1).
Update: I made a full backup with 2.1.2 on local disk, removed the app, reinstalled it from Play and tried to restore the backup.
MSPro confirms the backup, warns me that it will completely overwrite the library, and then immedeately aborts with something similar to "this is not a valid backup".

I restored MSPro 1.9.6 from a Titanium backup and it happily restored the backup.

Mike, could it be that something has changed in 2.1.2 w.r.t. disk/file access? When I tried to point MSPro at the backup (local file) I got different file lists and selection dialogs.
Hi Johan,

I definitely don't like the sound of that at all. The newest update definitely shouldn't have caused problems like that. It sounds to me like your database didn't update to the latest version. I have a test build I can send to you that will probably get past those update errors allowing you to use 2.1.2. Shoot me an email at if you want to test that so I can send you a link. If you want to manually check the database, look at the user_version and let me know what it says. 43 is the latest version - if it's below that, then that is definitely the problem. You would be the third user I've spoken to who has encountered this, so I may need to put out an update.  It does mean that there could potentially be issues in your database though, as not being able to update the database is always a bad sign. Those issues would be mainly with annotations. The latest update just exposes this problem more severely as I changed a data structure that every song utilizes when loaded, so it causes a crash if the database doesn't have the correct tables in place. 

I don't think anything has changed in v2.1.2 in regards to disk/file access. What was the last version you were using? I changed the backup/restore dialogs awhile ago to give users the choice to pick the source/destination without having to do it in the file browser itself.

Well, as you may recall from some earlier discussions, my database version is 40. It has been refusing to update for a long while, so the theory that it is now definitely missing crucial tables seems sound. I usually update MSPro with every release, so I'm sure I didn't have a malfunction with 2.1.1. (I'm currently at 1.9.6, since that was the easiest to restore. Otherwise I would have gone back to 2.1.1.)

I assume that when MSPro loads the database and detects an old version, it tries to perform an upgrade? And that this, at least partially, succeeds since (if I recall correctly from earlier discussions) my database contains at least some of the post-40 tables.

Wrt. the disk/file access: The older MSPro opened the previous location, the newer MSPro did not, but that may be due to the fact that I made a clean install.
Thanks to Mike's never ending support this has been solved now. It turned out that a couple of small errors in my database, accumulated over the many years that I used (and sometimes abused) MSPro, finally managed to trip some of his code.

The chances of this happening to less extreme users is extremely small.

Thanks again, Mike!
Anything special that other users should know? Should I take care when I use your MSProTools?
No, it is not related to any of my tools. Most likely cause is some unfortunate system crashes, or an old database upgrade that silently failed.

If your database version is 43 and all your annotations appear as they should there is nothing to worry about.

Mike: Maybe display the database version on the "About" screen?