MobileSheets Forums

Full Version: More backup/restore problems
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
On tablet, all files are not managed by MSPro. Storage location is SDcard.
All files reside under the Android/data/com.zubersoft.mobilesheetspro/files folder.
I make a backup to Google Drive.

On phone, all files are not managed by MSPro. Storage location is SDcard.
I restore the backup from Google Drive, to original locations.
Upon completion there is a message that some files could not be written due to file permissions or path mismatches.
I perform a Settings > Check missing files.
It reports 3 missing files. (The other 2 missing files are zero size and not copied)


The 3 missing files, 2 of which are visible in the screenshot (top entries), refer to storage location C443-17EE which is the storage location of the tablet. However:
- these files are not on the tablet (although they once were)
- they are not in the database on the tablet
- they are not in the backup file

When the backup file is restored on the phone, everything is wiped, isn't it?
- these files are not on the phone (although they once were)
- these files are not in the database on the phone
Where does the 'missing' information come from?

I stop MSPro and restart it, and again perform a missing file check. There are now 6 files missing. Huh? The 3 missing files above are disappeared.

Could it be that the database wipe is not sufficiently dealt with, or that parts survive in a cache?

Among the missing files is Partituren/Afasiekoor/10_Sinterklaas.cho. Sounds familiar? That's right, this is song with id 10, but I thought the stripping of the numeric prefix was fixed in 2.3.0?

Then I decided to uninstall MSPro, verified there were no leftover files, and reinstalled from Google Play.
I set it to not manage the files, storage location on SDcard, expose database.
I restored the backup again.
Everything went flawlessly. Checked for missing files: nothing is missing. All songs are shown in the overviews (songs, collections, ...)
Close MSPro and restart, checked again: all song files are missing.
In /storage/XXX-XXX/Android/data/com.zubersoft/mobilesheetspro/files is only mobilesheets.db. No song files.

Tried again: same.
When it said no files are missing, I tried to actually view a song and got the message that the file was missing. Checked again: all song files missing.
Tried again: same.
Tried again: now all files are really restored.
Tried again: now all files are really restored.

There is something wrong here, and I'm not sure it is MSPro...
It sounds to me like there may be an issue with restoring a backup file and then immediately using the "Find Missing Files" feature. The fact that you restarted the app and got different results makes me think that... I'll have to try that out myself.  As far as the database, I completely delete the file and create a new instance of the class that manages all the library data, so I'm not sure how there could be anything surviving in a cache. You are correct that 2.3.0 has the change to no longer try to strip out numeric prefixes for MobileSheetsPro backup files.

I have been able to reproduce the "ghost files" (e.g. "Hand Jive") issue on another device. But that device most likely contained roughly the same screwed up database + files as the phone from posting #1. It does, hoewever, rule out hardware and OS issues.

I could not reproduce the case that all files checked okay while not there.

Quote:It sounds to me like there may be an issue with restoring a backup file and then immediately using the "Find Missing Files" feature.

Although the bigger issue may be how a backup can be successfully restored without writing even a single file to the storage.
I did a new restore of a backup set and ended up with one missing file. A file that was in the old database, but not in the backup set. After restarting MSPro everything is okay.

So there seems to be a condition that left-overs from the current library interfere with the restored library until restart.

I've got a reproducible case now. It involves two backup sets. When I clear the library, restore (to original locations) backup set 2018-07-08 everything looks okay. Check a couple of files, restarting MSPro. (*) When I then restore backup set 2018-08-03 I get a restore warning that some files could not be restored, and find missing files shows the three ghost files. Stop MSPro and restart, and find missing files will report three other files that are missing. These files are in the backup set but somehow two got restored to a different location and the third is really missing. I sent the URLs via mail.

(*) Sometimes I get no files restored so they are reported all missing. Sometimes it reports no missing files but says there are 0 songs. I hope you can reproduce that, too.
New test...

Brand new install of MSPro. Configured the library location to sdcard, no manage, expose db.
Restore backup from google drive.
All went well. "Find missing files" reports no problems.
Restart MSPro: "Find missing files" reports all files missing.
The storage location only contains mobilesheets.db in its files folder.

I see this message in the system log:

08-07 10:41:35.424 E/SQLiteDatabase( 1538): Couldn't mkdirs /storage/032F-1110/Android data/com.zubersoft.mobilesheetspro/files/mobilesheets.db
08-07 10:56:21.753 E/UserRestrictionsUtils(  848): Unknown restriction: com.zubersoft.mobilesheetspro
08-07 10:56:24.313 E/AppInfoBase( 3682): Exception when retrieving package:com.zubersoft.mobilesheetspro
08-07 10:56:24.313 E/AppInfoBase( 3682):$NameNotFoundException: com.zubersoft.mobilesheetspro
08-07 10:56:24.421 E/PermissionPresenter( 5034): Error getting package:com.zubersoft.mobilesheetspro
08-07 10:56:24.421 E/PermissionPresenter( 5034):$NameNotFoundException: com.zubersoft.mobilesheetspro
08-07 10:59:38.587 E/SQLiteDatabase( 3461): Couldn't mkdirs /data/user/0/com.zubersoft.mobilesheetspro/databases/mobilesheets.db

Strangely enough, /storage/032F-1110/Android data/com.zubersoft.mobilesheetspro/files/mobilesheets.db is present and filled.
I'll work on trying to reproduce that. Question: did you restore settings from the backup file? If so, are the storage settings in the backup file the same as the storage settings you set up before restoring? I just want to make sure my test environment matches yours.

Yes, I always restore the settings from the backup, and the storage settings on all devices are the same (not managing, sdcard, expose database).
I was able to reproduce the problem, and it was an unusual error in the storage access framework where it said it couldn't create the files. No idea why that would be. After a reboot of the device, and deleting the folder and all files under it, I'm now no longer able to reproduce the problem. Each restore off Google Drive succeeds and there are no missing files. Weird...

Good job. So it is not all my fault Big Grin . I'll remember to reboot my devices when strange things start to happen.