MobileSheets Forums

Full Version: Upload problem with Google Drive
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
This has bitten me a couple of times before I found out what is going wrong.

I synch a device to GDrive folder "XXX". Sometimes this fails, e.g. because of network IO errors.
To make sure that I have a "clean" synch folder, I remove the folder XXX, and create a new one, using the web interface.
In MSPro. I run a new synch to folder XXX. Everything goes well. When I run the synch again, it completes without doing anything, just as can be expected.

However, on the Google Drive, folder XXX is empty.

My guess is that MSPro caches (maybe involuntarily) the drive handle of the folder. When the folder is removed, it is moved to trash but the handle stays valid. The newly created folder will get a new handle. Due to the caching, MSPro dutyfully performs the synch... directly into the thrash.

EDIT: My guess is confirmed when I "delete forever" the thrashed folder using the web interface. When I then request MSPro to perform a new synch, it briefly displays a message that it cannot access a specific GDrive handle before showing the folder picker.
Thanks Johan - I will add some code to ignore trashed directories if the saved handle happens to point to that.

(Unrelated?) Download error: