MobileSheets Forums

Full Version: Crash after second annotation [solved]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have to admit, I haven't yet understood how exactly to proceed for making annotations within larger PDFs.

A first annotation (e.g. inserting a coloured rectangle) isn't a problem. But if I try to add a second annotation (= not a second element, but a second saving to add new annotations to existing ones), the app crashes every time: I can add those annotations, but every time I hit the (x) button on the top left, it's off and away. It's reproduceable. I use the feature to save annotations directly within the PDF.
If you go to Settings->About, can you verify you are running version 3.0.4? I'm also working on releasing version 3.0.5 which has bug fixes in place for a number of issues.

Hi, you must have done just the right thing! The feature works like a charm: Editing PDF annotations multiple times in whatever combination!
I'm on 3.0.6 at the moment.
Just adding my .02 since I was also having a problem with saving directly to the PDF. If you really need the annotations saved into the PDF for some reason, you can just export the file and choose to include annotations. I found that without the save to PDF function on, the app was a lot speedier, too. Hope this helps a little!
I'm still very happy with direct PDF annotations. There is only a little issue left.

Sometimes, I can't delete an annotation (happend with the marker function) if there are others very close. I try and try - but don't want to get the others deleted, too. When I happen to delete one of those I didn't want to delete, I of course use the undo function - and MAGIC MAGIC get the one I didn't want to delete back, but the others I tried to delete multiple times are gone and away! So there must be a refresh error somewhere! In fact, they HAD been deleted - just wasn't seen.
In those kinds of situations, I would recommend using the layers popup to select the annotation you want to delete, and tap the trash can icon to delete it. This will prevent any accidental deletion. I will see if I'm able to reproduce what you are describing with deleting multiple annotations at once but not seeing the delete actually occur.

fziegler - Can you please take a song that demonstrates the issue, long press it on the library screen, tap Share->Export as .msf and send the .msf file to Also let me know which annotation to erase before hitting undo to see the problem occur. If you can take screenshots or make a short video with your phone, that would help a lot also. I'm unable to reproduce the problem at the moment, so this will help me determine where the issue is.