• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CompanionPro CRASHES in Windows 10 running in VMware on a Mac
This is MobileSheetsCompanionPro 2.4.0 running on Windows 10 in a VMware Fusion virtual machine on my Mac.

When I try to do a Batch Import, and browse for the folder, MobileSheetsCompanionPro CRASHES when I browse to a shared folder located on my Mac. The sharing is via VMware Fusion folder sharing -- to the Windows 10 guest it looks like a networked drive (Z: ). This happens for both of my tablets (Hannspree 13").

BUT: I can use the Windows Explorer to browse to the desired shared folder and drag-and-drop the folder from explorer into the batch import dialog folder field: -- batch import works just fine. (I can also drag-and-drop individual files from a shared folder into the main window just fine.)

CLUE: Using the same version, MobileSheetsCompanionPro 2.4.0, running on Windows 7 in a VMware Fusion virtual machine on my Mac, I never had this problem.

Granted this may be difficult to test, but I suspect that any networked drive might display the problem, not just the VMware virtual network.

At least I have a workaround. All my files are on my Mac (>1200 songs, some >100 pages), and I often transfer dozens of songs at once. A second workaround would be to copy them to C: and do batch import from there.

BTW my Windows 7 virtual machine is 45 GB, while the Windows 10 VM is just 13 GB. I'm running out of disk space, so I have incentive to move to Windows 10.
I use a custom browser for the batch import that can show both files and folders at the same time while picking a folder. Unfortunately, it sounds like it's not handling something correctly with the shared folder you are using. Are there any permissions that would prevent the companion app from accessing some of the folders inside that shared folder? An exception must be thrown somewhere during the processing, but it will be hard for me to locate without knowing how to reproduce the issue. I tried this with a mapped drive in Windows 10 (using my NAS), but that worked fine, so a shared folder must be a little different.
I think I may have found a few things that could help avoid this crash. I'll have to have you test it with the next release.

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.