• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Encoding confusion
#1
I noticed that some of my ChordPro songs needed an encoding fix (thanks for the feature Smile). I think this is what happened.

All of my songs are encoded using UTF-8. However, for reasons not relevant here, some files got replaced by ISO-8859.1 (Latin1) encoded versions. This was correctly detected by MSPro (I assume since the file could no longer be loaded using UTF-8) and dealt with. Later, the Latin1 version was replaced again by a UTF-8 encoded version. This was not detected by MSPro (every sequence of bytes is valid Latin1). As a result, the UTF-8 encoded file was treated as Latin1, showing all kinds of funny characters.

If this was the case, a fix could be to always try UTF-8 encoding first when a file is refreshed.

However, I must emphasize that I do not think this is a big issue. Only encoding geeks like me will suffer Smile .
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply


Messages In This Thread
Encoding confusion - by sciurius - 10-23-2015, 06:59 AM
RE: Encoding confusion - by Zubersoft - 10-24-2015, 02:37 PM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.