• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble getting MS Pro to work with my Korg PA3X Arranger
#1
Greetings all,

I just recently installed MS Pro on my 10 inch Acer Transformer tablet (running Android 4.1.1) after reading that I could automate the loading of songs by making songbook selections on my Korg PA3X Arrange Keyboard.

- I have configured "Midi Settings" to use midi channel 1 and set "Midi Device" to Korg.

- I have edited a song to add a midi command of type "Number" (where Number =1), and both the "Send on Song Load" and the "Load Song on Receive" fields are ON.

- I have followed the instructions on the following Korg Publication: http://www.zubersoft.com/mobilesheets/ma...s_korg.pdf to set up my Korg, with the only difference being that I set the control channel to be channel 1 for both midi-in and midi-out because I read in another thread that people were having trouble using a channel other than 1...

- I have setup one of the midi songs in my Korg's songbook to be labelled as song number 1, as described in the zubersoft korg instruction manual

- I have connected the table to the Korg's USB type B (square) connected through a simple adapter which is a USB Type A (female) on one side for connecting to my tablets USB cable and a USB Type B on the other side for connecting to the Korg.

- When I connect the table to the Korg, I have no indication in MS Pro that a connection is being made, and selecting a song on the Korg does NOT load the song on MS Pro or vice-versa.

Any thoughts? Of course any help would be extremely appreciated.

Regards,

Kleo
Reply
#2
There is no longer any issue using a channel other than one. The official document says to use channel 16 - can you give that a try and see if it makes a difference? The fact that you aren't seeing a message about the connection concerns me though. Normally you have to approve the USB connection. What kind of connector are you using for converting from USB to micro USB? I'm not sure if every adapter is made equal for that. I had to order an OTG Micro USB cable.

Thanks,
Mike
Reply
#3
Hi Mike,

Thanks for responding so quickly!

I did try channel 16, that was my first attempt since that's what the official document says. I then switched to channel 1 to see if it made a difference and it did not.

I have attached a photo that shows what connectors I am using to connect my tablet to the Korg keyboard. My tablet doesn't not have a standard or mini-USB port, it has only the one port & supplied cable for charging with AC and for connecting to computers. I am using the cable that came with the tablet (long thin connector on the tablet side and a USB connector at the other end) and converting standard USB connector at the end with an inexpensive adapter that changes the connector from USB type A to USB Type B so that it can attach to the USB midi port on my Korg.

If you can have a look at the attachment and let me know what you think I'd appreciate it. 

Perhaps I need a different cable? Does the tablet have to have a standard midi port in order for this solution to work?

Regards,

Kleo
   
Reply
#4
In theory it should work, but I honestly don't know that much about the connectors/converters and their limitations. I know that when I tried to use a USB extension cable it made it impossible for me to connect my tablet to my keyboard. I was completely baffled by this, as I didn't think the USB extension should have any impact. As soon as I removed it, things started working again.
Reply
#5
Hi Kleo,

I went through some of the same. I have a Samsung 12.2 and a Korg Kronos. I needed the OTG cable for the tablet, the charging cable did not work. Also, I tried one of those adaptors from USB A to B. That didn't work for me either. My path is OTG cable on the tablet with a USB cable going from USB A to B into the keyboard.
Reply
#6
I too am having this problem with a Samsung Galaxy 12.2". I use the external micro SD card for my music storage and if I remove that to access the OTG port, how do I 'see' my songs?
I have tried to use the charging cable to patch to the Korg PA 600, but there is no hand-shake between the two. Do I need to have the data loaded onto the tablet and the external card, and how do I do that?
Reply
#7
maintech

Are you saying you have an external micro SD card in a OTG adaptor plugged into the USB port of your tablet? If that is the case, then you can't use the USB port to connect to the Korg at the same time. It may be possible to use a USB hub to increase the number of USB ports available, but I haven't tried this.

If you plug the microSD card into the card slot on the tablet then there should be no problem using both that and the USB port. I have just checked with my Galaxy Tab S and I can use both the microSD card in the SD card slot and a USB memory stick plugged in the OTG/USB port.

jfree
You need to be careful using charging cables. Sometimes these are not suitable for data. To be sure I would get a good quality USB cable that is specified as suitable for data and if you can, check it works connected to a PC. The same applies to the adaptors. Some only have the charging/power lines connected. So are not suitable for data.

HTH

Andy
Reply
#8
Andy, I'm fine. That was my point, that the charging cable probably wouldn't work.



Sent from my HTC One_M8 using Tapatalk
Reply
#9
I contacted Samsung on live chat and was told that an OTG cable was to be used in the same slot as the charging/USB uses, that the slot for the external sd card was not to be used. I'm searching local electronic stores for a cable and will get back when I use it. It's a shame that the tablet manual lacks that information, but it should be added the the Korg manual, to prevent frustration of such nice people as us  Wink.
Reply
#10
(06-09-2015, 10:55 PM)maintech Wrote: I contacted Samsung on live chat and was told that an OTG cable was to be used in the same slot as the charging/USB uses, that the slot for the external sd card was not to be used. I'm searching local electronic stores for a cable and will get back when I use it. It's a shame that the tablet manual lacks that information, but it should be added the the Korg manual, to prevent frustration of such nice people as us  Wink.

You might be better off ordering it online.
Reply
#11
Hi Guys,

I'm convinced enough about the OTG cable being the solution that I've ordered one from Amazon. It should get here in a few days and I'll let you all know how it goes.
Reply
#12
(06-21-2015, 11:00 AM)kleanthis Wrote: Hi Guys,

I'm convinced enough about the OTG cable being the solution that I've ordered one from Amazon. It should get here in a few days and I'll let you all know how it goes.

Hi, any news if the purchase of the right cable has solved the issue?
What is version of your android system?
Reply
#13
(11-11-2015, 07:16 AM)pawlikp100 Wrote:
(06-21-2015, 11:00 AM)kleanthis Wrote: Hi Guys,

I'm convinced enough about the OTG cable being the solution that I've ordered one from Amazon. It should get here in a few days and I'll let you all know how it goes.

Hi, any news if the purchase of the right cable has solved the issue?
What is version of your android system?

I had trouble getting an OTG adapter, (obtained thru'  http://www.yellowpages.ca/bus/Ontario/Co...ntext=true)
and also found that using a USB-A male to USB-A female then a USB-A to USB-B was another problem. I solved this with a dedicated Samsung OTG male plug that has a female USB-A socket, and connected the keyboard with a printer cable, USB-B into keyboard, USB-A into adapter. I found that then following the instructions re Mobilesheets settings works just fine. I use channel 16, but it is important to stick to the described sequence; 

On the keyboard, after creating a song, it is important to give it a number. On the PA600 numbering is found in the Edit 3 page. Once the song is numbered, you need to provide Mobilesheets that number. A long press on the 'song' brings up the first menu, select 'edit', select 'midi', press the 'plus sign' to bring up the midi menu, select both 'Send on load' and 'Load song on receive' to 'ON' press 'Patch select' for menu, select 'number', press the '0' to bring up the numerical pad, type in number from songbook in keyboard, be sure to delete the leading '0' the the number pad displays, press 'done' on keypad then 'OK' in the 'Enter the Value' box, next 'OK' on the top menu, right hand side.


Attached Files Thumbnail(s)
   
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.