• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Receive Program Change
#1
Hi and thanks for the fixes in MSPro 1.0.6

I'm trying to load songs receiving Midi program change via usb on my samsung Galaxy note 10.1
I see with an app called "USB midi monitor" that the tablet receive the program changes
I've created midi commands for songs, with "load song on receive: on"
But nothing happens

It work well in the other way, sending program change to my midi pedal board

Am I doing something wrong here, or don't understand the feature?
Reply
#2
- Make sure you have a different song displayed than the one you are trying to load (or that the song you are trying to load was not the last one displayed if you are on a library screen). If not, MSPro will think the song is allready there and will not display it again
- make sure you send on the sight channel
_____________________________________________________
HP Slate 21-Android 4.4.2, HP Slate 17-Android 4.4.4, Onda Air 10" (backup tablet) Android 4 / Windows 10
Yamaha Genos, Roland PK-6, Yamaha PSR SX900
Reply
#3
Hi Rey
I was on the right channel and took care of being on another song of my setlist
I'm using a ESI midimate 2 wire, midi to USB, maybe it doesn't work like it should
Reply
#4
If it works for 'usb midi monitor' it should also work for MSPro I guess ...
I suppose you do get the message, asking if MSPro can have access to the usb device?
Maybe it has to do with some MIDI systems beeing 0 based and others 1 based.? In that case you may need to configure one system, 1 digit higher or lower than the other ....
_____________________________________________________
HP Slate 21-Android 4.4.2, HP Slate 17-Android 4.4.4, Onda Air 10" (backup tablet) Android 4 / Windows 10
Yamaha Genos, Roland PK-6, Yamaha PSR SX900
Reply
#5
Yes I've got the MSPro access message
And if I plug it again, I've got another message, I've attached a picture of it
My guess is that the wire ESI midimate 2 and my tablet samsung GT n8010 are not fully working together
The 2 midi connectors should be either midi in or midi out, depending where it's plugged
But when I'm sending midi commands from MSPro, it only works in connector 1

I've took care of the midi offset, but thanks for your ideas Rey


Attached Files Thumbnail(s)
   
Reply
#6
In my experience you cannot choose which midi connector to use for in and out. One is the IN the other is the OUT. If you connect them otherwise it will not work. But as said, thats in my experience with midi.

If you consistently get good results in 'usb midi monitor' when sending commands to the tablet, then it feels logical to me, to think that the cable is ok and that it is the config in MSPro or MSPro itself that is not ok.
I use MSPro to load sheets based on midi commands myself, so on my tablet at least MSPro is ok with that.
I would at this stage play around with the midi offset (also in the midi channel) Meaning that if you currently send a 5, try sending a 4 and if no result, then trying a 6.

What command is configured in MSPro? 'Patch select', 'program change' ... I use 'patch select' I cannot remember if I tested with any of the other commands ...
_____________________________________________________
HP Slate 21-Android 4.4.2, HP Slate 17-Android 4.4.4, Onda Air 10" (backup tablet) Android 4 / Windows 10
Yamaha Genos, Roland PK-6, Yamaha PSR SX900
Reply
#7
From the ESI midimate 2 manual (http://www.esi-audio.com/products/midimate2/):
USB MIDI interface with 2 MIDI connectors, each can work as independent input or output
Using MIDIMATE II with your applications could not be easier.
If you connect the MIDI cable to a MIDI Output of an external device, signals will appear via MIDI input in your software.
If you connect it to a MIDI Input, you can send signals to the external device via the MIDI playback function of your software

It's supposed to be plugged in a computer, but as it's class compliant, it works with my tablet
But maybe not in the right usb busses for MSPro, I don't know much about how the tablet deal with midi commands

I'm quite sure it's not an offset issue, as I've tried sending 4 and 6 instead of 5, and I can see with "USB midi monitor" that I'm receiving Program change 4 when I send 5
I'm using Patch select, with msb:0, lsb:0 and value:4

Glad to know it can work
Do you have the reference of your cable?
Reply
#8
I am using Roland UM-ONE mk2, also for Windows not Android but it works.

In one of my configurations I am sending MSB 0, LSB 1, PC 28 to the tablet

In usb MIDI monitor I see 3 lines coming in
- control change 0 0 Bank select
- control change 32 1 Bank select
- program chg 27 0

Are you seeing something similar in your usb midi monitor?
_____________________________________________________
HP Slate 21-Android 4.4.2, HP Slate 17-Android 4.4.4, Onda Air 10" (backup tablet) Android 4 / Windows 10
Yamaha Genos, Roland PK-6, Yamaha PSR SX900
Reply
#9
Here's what I see in usb monitor when I press preset 5 on my pedalboard:

17:47:33:059: Control change, Channel 1, 0, 0, Bank Select
17:47:33:060: Program change, Channel 1, 4, 0
17:47:33:810: Control change, Channel 4, 0, 0, Bank Select
17:47:33:863: Program change, Channel 4, 4, 0
17:47:33:864: Control change, Channel 5, 0, 0, Bank Select
17:47:33:864: Program change, Channel 5, 4, 0
17:47:33:865: Control change, Channel 6, 0, 0, Bank Select
17:47:33:865: Program change, Channel 6, 4, 0
17:47:33:865: Control change, Channel 7, 0, 0, Bank Select
17:47:33:866: Program change, Channel 7, 4, 0
17:47:33:866: Control change, Channel 8, 0, 0, Bank Select
17:47:33:867: Program change, Channel 8, 4, 0
17:47:33:867: Control change, Channel 9, 0, 0, Bank Select
17:47:33:868: Program change, Channel 9, 4, 0
17:47:33:868: Control change, Channel 10, 0, 0, Bank Select
17:47:33:869: Program change, Channel 10, 4, 0
17:47:33:869: Control change, Channel 11, 0, 0, Bank Select
17:47:33:869: Program change, Channel 11, 4, 0
17:47:33:870: Control change, Channel 12, 0, 0, Bank Select
17:47:33:870: Program change, Channel 12, 4, 0
17:47:33:871: Control change, Channel 13, 0, 0, Bank Select
17:47:33:871: Program change, Channel 13, 4, 0
17:47:33:872: Control change, Channel 14, 0, 0, Bank Select
17:47:33:872: Program change, Channel 14, 4, 0
17:47:33:872: Control change, Channel 15, 0, 0, Bank Select
17:47:33:873: Program change, Channel 15, 4, 0
17:47:33:873: Control change, Channel 16, 0, 0, Bank Select
17:47:33:874: Program change, Channel 16, 4, 0
17:47:33:892: Control change, Channel 1, 16, 0,
17:47:33:893: Control change, Channel 1, 17, 0,
17:47:33:893: Control change, Channel 1, 18, 0,
17:47:33:894: Control change, Channel 1, 19, 0,
17:47:33:895: Control change, Channel 1, 20, 0,

First number is midi channel, second is "value 1", and third is "value 2"
The pedal board send the program change on all midi channel by default, except channel 2 and 3, I've quiet those for a midi loop issue in my setup
The five last control change (16 to 20) are CC of the pedal board, 0 for off and 127 for on
I've tried a lot of configurations in the "load on receive" parameters in MSPro, different midi channels, with no luck

I think I have to try a cable like yours, with one connector in and one out, not "in or out" connectors
Reply
#10
I do not see the need for a different cable at this time, as the commands are coming in in usb midi monitor.

I did not mention the channel when writing the 3 lines I see in usb midi monitor, so the structure is the same of you are seeing, however:
I get 3 lines per command, you seem only to be getting 2 lines per command (per midi channel). And if you configured MSPro with patch select there are 3 fields, so I think it is looking for 3 commands.
Have you tried in MSPro defining a 'program change' or 'control change' in stead of 'patch select'. My guess is that this may trigger it, as this only has 1 or 2 fields respectively ...
_____________________________________________________
HP Slate 21-Android 4.4.2, HP Slate 17-Android 4.4.4, Onda Air 10" (backup tablet) Android 4 / Windows 10
Yamaha Genos, Roland PK-6, Yamaha PSR SX900
Reply
#11
I have just configured a 'program change' in stead of 'patch select' in MSPro and it still triggers. Cannot change what the instrument is sending though, so I cannot simulate your situation.
I suppose you cannot get your instrument to send 3 commands ?
_____________________________________________________
HP Slate 21-Android 4.4.2, HP Slate 17-Android 4.4.4, Onda Air 10" (backup tablet) Android 4 / Windows 10
Yamaha Genos, Roland PK-6, Yamaha PSR SX900
Reply
#12
I think you pointed my problem

What I understand from reading internet and tests is that:
Your first line CC 0 is the MSB (Most Significant Byte)
Your second line CC 32 is the LSB (Less Significant Byte)
Your third line is the program change Value

Seems like my pedal board (http://www.fractalaudio.com/p-mfc-101-mi...roller.php) just send MSB and program change lines
I think it's because it only needs 3 banks of 128 preset to control the Axe-Fx 2, but that's a shame!
That's why it works in the other way, when I'm sending Midi commands with MSPro, the pedal board has the two lines it needs (and ignore the LSB)

Yes, I've tried defining "program change" and "Control change" in MSPro, no results
I'm gonna check with Fractal audio if there's a way to send the LSB command

I thank you a lot for your help Rey, you made me save a usb midi cable
Reply
#13
Glad to have helped. Still find it strange the control change does not trigger either Maybe Mike will have something to say on this.
_____________________________________________________
HP Slate 21-Android 4.4.2, HP Slate 17-Android 4.4.4, Onda Air 10" (backup tablet) Android 4 / Windows 10
Yamaha Genos, Roland PK-6, Yamaha PSR SX900
Reply
#14
Hi all, I'm experiencing just the same problem as Furay. I have the same Midi cable. Tested it with my tablet Acer A700 with Cyanogenmod connected to a computer with Cubase. I could send and receive, even with exchanging the MIDI cables on the fly (the cable recognizes the ports). Sending patches worked fine to two devices - old Roland JV-30 and a TC electronic G-System. From both devices I couldn't receive program changes to load songs. I tried all of the above mentioned workarounds. So I feel it is most likely a bug - maybe Mike will have another idea ...
Not the most important feature maybe. The program on the whole is so much improved and really usable and helpful - thanks again, don't want to miss it anymore. Martin
Reply
#15
An addition to my last post above: After booting my tablet it receives MIDI commands as expected on my USB MIDI monitor. After starting MS pro No reaction - no songs loading. Then, after closing MSPro, and no other change in the setup: The MIDI Monitor receives no commands or incomplete commands with no obvious system. Maybe MSPro interferes with the USB interface? Sending MIDI works flawlessly whatever I try ... Martin
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.