• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Companion Pro Crashing
#1
Mike:

Since I have updated Companion to 2.09 I have not been able to back up.

I starts the backup and gets a little under 35% into it.  On the computer I get an error: "Mobile sheet has encountered a problem and must close . . . "

On the tablet a get up to "packaging" the song "My Foolish Heart"  (I am able to open that song on the tablet without a problem,, so it does not seem corrupted).  I think the last song it successfully transferred was Honkey Tonk Woman.  

It said it was "packaging" the whole time.  Does it always do this?

This has happened several times.  I tried restarting the tablet and the computer.

When I have re-started Mobilesheets, I was asked:"The program may have abnormally exited...Would you like to restore when you connect the tablet."

I have always said "no" because I wanted it to start fresh with the database on the tablet.

Mike, I'm hoping you can help with this.
Reply
#2
If it happens at the same song, it might actually be the song previous to this (or after). I would run a test by taking out a few songs before (after) that one and see what happens.
I presume there is enough space for it to create the backup wherever it is saving it to?
Also you could try deleting the companion app and downloading a fresh copy.
I do not know if it uses a cache while backing up and if it has left a remnant of it somewhere when it stops (Mike can tell us) but it might be causing some kind of problem if it does not start a new one each time you try the backup.
Reply
#3
Yes, I reinstalled mobilesheets and still had the problem.
Reply
#4
I was able to backup successfully on the tablet. So, the issue appears to be related to the Companion.
Reply
#5
I'm having no problems backing up here, using the latest releases.

There was a problem, related to Placeholder pages, that Mike has resolved (at least he solved it for me). Do you have any of these?
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply
#6
Thanks, for chiming in Grame. Nope, I don't think I have any placeholders. I have no idea what is causing the problem.

Maybe Mike can give me direction to make sure I can clean out all remnants of the program. Maybe that would help. It seemed related to updating to the new version.

[I wouldn't mind reverting to an earlier version of the MS Pro Companion and seeing what happens.]
Reply
#7
Jeff - I just released MS 1.1.2 and companion app v2.1.0. Could you please test with the latest versions and let me know if this is still a problem? I made a number of adjustments to the backup/restore to make them faster, and I just want to rule out any problems you are seeing that might have been fixed.

Thanks,
Mike
Reply
#8
Thanks, Mike, downloading new version now.
Reply
#9
Nope, same thing happened.  It stops at the same song each time.  It is in the middle of packaging "My Foolish Heart", it was transferring "Hot Stuff", and the last song transferred was "Honkey Tonk Woman".  All these songs open fine on the tablet (and I was able to backup on the tablet).

I guess my  suspicion is there is some problem from when I did the update.  Even though I removed the program and reinstalled fresh from the MS website, when I started the program, I got the prompt: "The program may have abnormally exited...Would you like to restore when you connect the tablet." (I said no).  

I wonder if I was able to get rid of all old files/code, etc. (so it did not give that prompt) whether that would fix the problem. (But I guess I don't really have a clue.  So, Mike, any help is appreciated.)

NOTE:  The Computer OS is Windows XP.
Reply
#10
Jeff,

There is slightly different code between the backup invoked from the companion versus a backup invoked from the tablet. I went over this code closely, and I can't see any discrepancies that would explain what you are seeing. Can you provide me some additional details about both of those songs? It would help to know the following:

1) How many files does each song use and how big are those files?
2) Have you associated audio files with either song? Are the audio files stored in the MS storage location, or elsewhere?

Hopefully we can get to the bottom of this quickly.

Thanks,
Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
2 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.