• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Restore is losing some files
#31
Thanks Graeme - the only bad thing about the problem being on the companion side is that the companion actually doesn't do any processing - it just streams the backup file over to the tablet, and the tablet uses almost the same exact code as when the restore happens only on the tablet. Time to start adding mp3 files to lots of songs to see if I can catch the error when it happens.

jfree - Go to Settings->Other Settings->Find missing files
Reply
#32
(06-04-2015, 01:45 AM)Zuberman Wrote: Thanks Graeme - the only bad thing about the problem being on the companion side is that the companion actually doesn't do any processing - it just streams the backup file over to the tablet, and the tablet uses almost the same exact code as when the restore happens only on the tablet. Time to start adding mp3 files to lots of songs to see if I can catch the error when it happens.

I did thnk Companion was actually doing very little, just hosting the file and then wirelessly transferring it.

From what limited information I can see, it would appear that the uploading of the backup (using Companion) is error free - the indication of pages being present is why I believe this, plus the fact that moving the whole backup file to the tablet and restoring from within the device is error free.

Which leaves us with what is happening when restoring through Companion?

I actually used a wifi link (Droid) to transfer the backup file to the tablet and this appears to be error free. I've done this quite often when beta testing and never seen any problems - in fact I use Droid nearly all the time for working between the PC and the tablets and never had cause to question it.

I guess Droid uses much the same wifi technology as Companion uses for transfer, but the latter seems to produce errors. I think that I would start my search with the transfer technology itself.

One more thing - I'm not convinced it's the presence of an audio file which triggers the error. Near enough all of the original missing files I had were only PDF's (and one text file) and nearly all of those had never ever been associated with an audio file.
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply
#33
Thanks, I thought you were talking about an external program. In doing the "find missing files" it showed that I've got 5. 1 I knew about. Now I've never used companion, only backed up to ext card and dropbox, only restored from card. These are all songs I've not opened in a while, not sure if there's any relevance there. Baffling though, and very random.
Reply
#34
(06-04-2015, 11:08 PM)jfree Wrote: ... I've never used companion, only backed up to ext card and dropbox, only restored from card.

Mike - that is worrying. I was convinced the problem lay with Companion, but this puts a whole different complexion on the problem.
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply
#35
(06-04-2015, 11:27 PM)GraemeJ Wrote: I was convinced the problem lay with Companion, but this puts a whole different complexion on the problem.

I think, I can confirm that this is not a problem of the Companion!
I have never used the Companion to change the database before (because I don't get a connection to my tablet), but I actually found 3 missing files in my database.

I then restored an pretty old backup made in the green mobilsheets version to the blue mobilesheetspro and found the same files as missing. I than restored the old backup to the green mobilesheets and then I could see, that these files are missing there too, because I get an error if I try to use them.

The problem of missing files seems to be a problem during backup or restoring of the green mobilesheets version, not of the Companion (because I bever used that before).
---------------------------------------------------------
13" - Point of View POV_TAB-P1325, Android 4.1.1
13" - Point of View POV_TAB-I1345, Android 5.1.1
Microsoft Surface Pro 4; Windows 10
Phone: Motorola Moto G3, Android 6.0
Reply
#36
Now we have two people who have never used Companion, but still have missing files it would seem Companion is off the hook Smile - at least, the current version, not sure about the old one.

One thing appears to be fairly certain, this problem goes back a long way - quite probably to the original MS. My backup (made with MS and the original Companion) was initially imported into MSP and it's quite possible the missing files were missing even then. If that is the case, then subsequent backups and restores just propagated the error.

Like many users, I have a fairly large collection of charts (2000+) and nobody with that many wants to start from scratch and re-build from nothing into MSP. When you have that many files, it's a real chore to check every one - and I, for one, never did. It's only since Mike introduced the diagnostics that we have started to get a handle on the problem.

What would be good would be to find a forum member, with an equally large database and who has only ever used MSP and see if they have experienced any missing file problems?

All that said, I refer you to post #28 in this thread - to me, that indicates there is still a problem with the current versions that needs to be resolved.

Obviously, I will now run the diagnostics every time I do a restore Wink .
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply
#37
Or, some one having the problem who still has the original charts on the computer that have never been through MS[P]. They could be labelled as a test package and put through various scenarios. Smile
Dell Latitude 13.5" 2-in-1 Win 10, ver 19.--
Samsung Note Pro SM-P900 12.2 Android 5.0.2
Asus TF700T, os = CROMi-kk_R1 KitKat-4.4.4r2-CM11-US DEODEX, Based on Android 4.4.4
Nook HD+ OEM
Reply
#38
Hmmm... I have some early backup files. The earliest is August 10th 2013. There are plenty more between that date and July 8th 2014. Naturally, the files sizes slowly increase as I added stuff. I would imagine that many of those have never been anywhere near MSP.

As I no longer have MS or the original Companion, I can't be certain what's in them.
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply
#39
Do you still have the source files that came before loading into either app?
Dell Latitude 13.5" 2-in-1 Win 10, ver 19.--
Samsung Note Pro SM-P900 12.2 Android 5.0.2
Asus TF700T, os = CROMi-kk_R1 KitKat-4.4.4r2-CM11-US DEODEX, Based on Android 4.4.4
Nook HD+ OEM
Reply
#40
That's a qualified maybe. I probably do still have them, but they will be scattered around all over the place and re-collating them would be a major effort - but it's one I will undertake if absolutely necessary.
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply
#41
I just wondered, I have two folders on the computer, one is for charts to be loaded into MS[P] and the other is for what has already been loaded. I just move them from one folder to the other after loading them. That way, when I screw up I have the source available. The first one is where I send my pdf files as I make them.
Dell Latitude 13.5" 2-in-1 Win 10, ver 19.--
Samsung Note Pro SM-P900 12.2 Android 5.0.2
Asus TF700T, os = CROMi-kk_R1 KitKat-4.4.4r2-CM11-US DEODEX, Based on Android 4.4.4
Nook HD+ OEM
Reply
#42
I'm obviously not as organised as you Smile . Over the years, I have acquired files from all manner of sources and fed them into MS/MSP. Since the ability to extract files from the backup *appeared* to work, should I need them (and I always had several backup files to extract from) I rather disregarded the need to collect all the files in one place.

However, I almost certainly do have them, just not in one place.
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply
#43
You have an 'over the years' collection, mine is more like 'over several months' and is only a few hundred Smile
Dell Latitude 13.5" 2-in-1 Win 10, ver 19.--
Samsung Note Pro SM-P900 12.2 Android 5.0.2
Asus TF700T, os = CROMi-kk_R1 KitKat-4.4.4r2-CM11-US DEODEX, Based on Android 4.4.4
Nook HD+ OEM
Reply
#44
I've got a couple of thousand Sad .

I was collecting this stuff in digital format, long before MS appeared on the scene - in fact it was the arrival of MS that made me take the plunge in Android-based tablets. Before then I was using a laptop and PDF reader - it worked reasonably well, but with nothing like the convenience of MS and MSP. If I had known then, what I know now, I would have organised things in a completely different way Smile .

Story of my life!!
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply
#45
I am now able to say that there is definitely something going wrong in the MSP-Companion (Sorry)!
First I actualised MSP on my childrens tablet (samsung 10.2) and restored my backup (MSP54, 3,22GB) from my POV-tablet. I checked for missing files after that and everything was ok.
Then I actualised MSP-Companion and made some changes (entering CUMSTOM-Information) during connection to the samsung. After that I stored a new backup MSP55.
Later I was wondering, that the modified (new) backup (MSP55 2,92GB) was much smaller than the one before. Then I looked for missing files (new diagnostic) again and found two files marked as missing! But checking the songlist I further found that one setlist had been gone completely, including all song sheets.
I have both backups available, but I think they are to big to mail.
---------------------------------------------------------
13" - Point of View POV_TAB-P1325, Android 4.1.1
13" - Point of View POV_TAB-I1345, Android 5.1.1
Microsoft Surface Pro 4; Windows 10
Phone: Motorola Moto G3, Android 6.0
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.