• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Restore is losing some files
#25
Update on missing file/s thingy:

I took my earliest MSP backup, from 27th March 2015, loaded it into Companion and set about extracting the missing files. These number 24 in total, disregarding the Placeholders, which contained no files anyway.

All of the missing files were in the backup, so I extracted them in the usual way, this gave me a set of directories, each one containing the PDF file for the piece concerned (there was one chordpro file as well, not usually used, but I was just checking it out).   I then moved the individual PDF's to another directory, from where I intend to do a batch import into MSP (having first deleted the file references in MSP itself).

NOTE: The function to batch delete missing file references in the missing file search tool is a good idea, but there is no option to retain anything one might want to keep - in my case, the Placeholder pages - so I have to delete each individual reference on the tablet from the library page.

Of the 24  files that should have existed, only 11 were actually there, the other directories were empty. If nothing else, it would appear this is a problem that has existed for some little time and not something that has suddenly popped up.

Checking the backup in Companion, the charts that were missing certainly appeared to be there, as there was a number in the 'Pages' column for every one of them.  Of course, that's as far as I can go, since it is not currently possible to view the pages in Companion, but Companion certainly believes these files exist - even if that's not true.

My next move was to import the recovered files, using the batch import tool in Companion.  I had to rename each one, as MSP still believed the original file existed. There was a problem with the chordpro file, see the screenshot.  Then I trawled through the library and deleted every title that reported a missing file.  Used the missing file tool again and there were a couple where the missing file was an audio file and I wasn't sure what to do about them.  My Placeholder files were still there as well.  In the end I made a note of the songs concerned and used the delete command to get rid of everything. 

I replaced the Placeholders and another run of the tool reported nothing missing (other than the Placeholders not having any associated files) so it would seem that everything on the tablet was hunky-dory.

Using Companion, I made a completely new backup, including the audio files. After the backup completed, I closed down MSP and Companion.

I fired up Companion again and loaded the new backup file.  This seemed OK, from what little one can tell in this mode.  I started MSP again and set Companion to do a restore of the backup I had just made.  Then I made myself a stiff whisky and waited for it to complete.

A couple of stiff ones later, the backup had completed and I ran the missing files tool - A FILE WAS MISSING [Image: angry.gif] !  Admittedly, an audio file, but missing never the less.  It was definitely there before I started all this nonsense.

It's late - three o'clock in the morning - I can do no more tonight.

Two screen shots attached - one from the tablet, showing the missing file it reported after I had gone through all the above stuff (you can disregard the Placeholders, they have no associated files) and the other showing an error when trying to import a chordpro file into MSP via Companion.


Attached Files Thumbnail(s)
       
Graeme

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
Reply


Messages In This Thread
Restore is losing some files - by FiddlerJeanne - 05-30-2015, 10:44 AM
RE: Restore is losing some files - by GraemeJ - 05-30-2015, 10:51 AM
RE: Restore is losing some files - by Zubersoft - 05-30-2015, 11:01 AM
RE: Restore is losing some files - by Marshland - 05-30-2015, 11:30 PM
RE: Restore is losing some files - by GraemeJ - 05-31-2015, 02:33 AM
RE: Restore is losing some files - by sciurius - 05-31-2015, 06:01 AM
RE: Restore is losing some files - by Zubersoft - 05-31-2015, 08:08 AM
RE: Restore is losing some files - by Zubersoft - 06-01-2015, 03:37 PM
RE: Restore is losing some files - by GraemeJ - 06-01-2015, 07:10 PM
RE: Restore is losing some files - by Rey_a - 06-01-2015, 08:01 PM
RE: Restore is losing some files - by GraemeJ - 06-01-2015, 08:25 PM
RE: Restore is losing some files - by Zubersoft - 06-02-2015, 01:37 AM
RE: Restore is losing some files - by GraemeJ - 06-02-2015, 03:09 AM
Restore is losing some files - by Rey_a - 06-02-2015, 03:23 AM
RE: Restore is losing some files - by itsme - 06-02-2015, 07:11 AM
RE: Restore is losing some files - by GraemeJ - 06-02-2015, 10:25 PM
Restore is losing some files - by Rey_a - 06-03-2015, 12:12 AM
RE: Restore is losing some files - by sciurius - 06-03-2015, 12:43 AM
RE: Restore is losing some files - by Rey_a - 06-03-2015, 12:45 AM
RE: Restore is losing some files - by GraemeJ - 06-03-2015, 01:56 AM
RE: Restore is losing some files - by Zubersoft - 06-03-2015, 02:04 AM
RE: Restore is losing some files - by GraemeJ - 06-03-2015, 11:22 AM
RE: Restore is losing some files - by Zubersoft - 06-03-2015, 02:07 PM
RE: Restore is losing some files - by GraemeJ - 06-03-2015, 10:30 PM
RE: Restore is losing some files - by GraemeJ - 06-03-2015, 10:38 PM
RE: Restore is losing some files - by jfree - 06-03-2015, 11:20 PM
RE: Restore is losing some files - by GraemeJ - 06-03-2015, 11:38 PM
RE: Restore is losing some files - by Zubersoft - 06-04-2015, 01:45 AM
RE: Restore is losing some files - by GraemeJ - 06-04-2015, 02:49 AM
RE: Restore is losing some files - by jfree - 06-04-2015, 11:08 PM
RE: Restore is losing some files - by GraemeJ - 06-04-2015, 11:27 PM
RE: Restore is losing some files - by Vibraphon - 06-04-2015, 11:52 PM
RE: Restore is losing some files - by GraemeJ - 06-05-2015, 12:29 AM
RE: Restore is losing some files - by Skip - 06-05-2015, 02:12 AM
RE: Restore is losing some files - by GraemeJ - 06-05-2015, 02:47 AM
RE: Restore is losing some files - by Skip - 06-05-2015, 03:00 AM
RE: Restore is losing some files - by GraemeJ - 06-05-2015, 03:11 AM
RE: Restore is losing some files - by Skip - 06-05-2015, 04:10 AM
RE: Restore is losing some files - by GraemeJ - 06-05-2015, 08:03 AM
RE: Restore is losing some files - by Skip - 06-05-2015, 09:42 AM
RE: Restore is losing some files - by GraemeJ - 06-05-2015, 10:03 AM
RE: Restore is losing some files - by Vibraphon - 06-07-2015, 03:18 AM
RE: Restore is losing some files - by Zubersoft - 06-07-2015, 04:28 AM
RE: Restore is losing some files - by Vibraphon - 06-08-2015, 08:01 PM
RE: Restore is losing some files - by CholitoWeb - 06-23-2015, 06:20 PM
RE: Restore is losing some files - by Zubersoft - 06-24-2015, 02:23 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.