• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
collection editor problem
#1
I'm pleased to report that as of MobileSheetsPro version 1.3.3 the sort order issues appear to be solved, both when viewing a collection and inside the collection editor.

...but the problem of the wrong song being deleted in the collection editor is still present (or present again, as the case may be), exactly (word for word!) as described in http://zubersoft.com/mobilesheets/forum/...81#pid3181

There is a workaround:  in the collection editor, change the sort setting from A-Z to Manual; in Manual sort mode, the correct song is deleted.  I didn't think to try this back when the problem originally surfaced in the original MobileSheets, so I don't know whether it would have worked there.
Reply
#2
That should be easy enough to reproduce. I believe I might even know the code responsible for the bug. I'll take a look at it tomorrow.

Thanks,
Mike
Reply
#3
After looking into this issue, I actually found a lot of problems that could potentially occur when combining all of the different options that affect sorting (custom sort title, use song title for formatting, ignoring articles, etc). I also found errors in the logic with the collection editor (the same code is used for all of the group editors). Thanks again for letting me know about this.

Mike
Reply
#4
This just started happening to me with the latest version. If I'm in edit mode the "greyed out" songs in the right column do not change if I try to remove one. It will stay highlighted and some other song will vanish. If I keep hitting the same selection it will keep removing songs.
Reply
#5
I can see this behavior as well - I'll get it fixed ASAP. I believe if you tap the "X" on the left list, it works correctly. Additionally, if you switch to "Manual" sorting, it also works if you tap on the same item multiple times.
Reply
#6
It is the Tablet Vers. 1.3.5

THANKS

Just an update-still wonky on 1.3.6
Reply
#7
Correct - it will be fixed for 1.3.7 as I didn't know of the problem until after 1.3.6 was released.
Reply
#8
All seems to be well again in 1.3.8 cheers!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.