• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Version Issues
#1
I'm running into issues with version compatibility between the companion app and the app on two of my tablets.
These are older tablets, and the one in front of me is running Anrdoid 3.1.
I downloaded my MSPro app from the Amazon AppStore, and up until today everything has been working fine. Three other tablets have been updated to ver. 1.4.2 by Amazon.
I updated a song today on a newer tablet I normally use for this, and used the companion app to backup my files (after getting and installing the latest update, of course!).
Since I want all of my tablets to have and display the same songs, playlists, and settings, I have been using the restore feature on each tablet in turn to restore the saved backup.
Today I find that is not possible on these older tablets, since the Amazon AppStore will only install ver. 1.3.2 on the tablet, and the newer companion app will not sync with ver.1.3.2. Exclamation

Even worse, I deleted MSPro from the tablet, thinking I could 'force' the newer version when I re-installed...no dice...and now I have a tablet with NO music on it. Angry

What, if anything, can I do to solve these issues?

Steve

EDIT: I'm trying a 'stand-alone' back-up on one of the newer tablets to see if I can restore it after copying to a storage location on the 'blank' tablet, wish me luck!
I could be wrong, it happened once before.
Reply
#2
Steve,

Please try something for me: On the device that can't install the latest version, uninstall the Amazon App Store, and then install Amazon Underground. Now, search for MobileSheetsPro and try to install it. Let me know if this changes anything.

Mike
Reply
#3
You caught me just in time, I was almost ready to use the back-up file.
I'll report back in a few minutes...
I could be wrong, it happened once before.
Reply
#4
Unfortunately, that didn't help much.
'Amazon Underground' won't run properly, just a blank screen. I tried a re-start, but that didn't help.

Perhaps re-installing the Amazon App Store will have an effect? I'll try that.
I could be wrong, it happened once before.
Reply
#5
Yes, definitely give that a shot and let me know how it goes.
Reply
#6
No go.
Amazon Underground won't run.
Re-installing Amazon App Store produced no results.
Attempting to use a back-up from the higher version threw an error when attempting to view a song, although the loading of the back-up seemed to work properly. I tried using backed-up settings, and not using them, same results.
I can accept that these tablets have reached the end of their useful life for this application, but it would be nice if I could go back to a previous version of the companion app and still 'sync' them as before.
I wasn't having any issues with the older version.
I could be wrong, it happened once before.
Reply
#7
That is really strange. Unfortunately, you'd need to talk with Amazon support to figure out why their app store is not letting you update the app. If you want to install an older companion version, you can find them archived here: http://zubersoft.com/mobilesheets/archive

It is really dangerous to restore a backup from a newer verison in an older version. At best, some features may not work correctly, and you will receive database errors when you try to access them. At worst, it could render the library unusable on that device. I definitely would recommend against doing that.

Mike
Reply
#8
Thanks Mike, I was hoping there was an archive of older versions somewhere.
So, from your discussion, it sounds to me as if you know of no reason the latest version shouldn't run on my older 3.1 tablet?
I have ES File Explorer, and am going to try 'side-loading' an .apk made off one of the updated tablets and see what happens...it seems I have little to loose.
If that doesn't work, I can still use a database back-up from the other tablet (that won't update) that still has it's database intact.

Steve

EDIT: Well, that seems to have worked!
Installed the .apk created on another tablet and restored the library normally with the companion app.
I could be wrong, it happened once before.
Reply
#9
The latest version should run just fine on your older tablet. Side-loading an .apk should technically work, as long as it matches the one downloaded from the amazon app store.

Mike
Reply
#10
Everything seems to be working properly now, I've given that tablet a thorough test over the last few hours.

After thinking about it, I now recall that some of my tablets (not sure which ones) seem to have had their updates delayed in relation to some others. Perhaps I would have gotten the update eventually if I had been patient.
I could be wrong, it happened once before.
Reply
#11
Hmm, most recent update has still not come to the older tablets.
I contacted Amazon about the issue, but they were not able to provide a solution after passing me through several 'support technicians'.
They asked for my phone number, and two hours later I have not heard from them.
At one point they stated I needed to contact the developer, of course I stated that I had already contacted the developer!
Luckily, I can still 'side-load' the .apk I can develop from the tablet(s) that can/will update from Amazon.
Needless to say, this episode makes me wary of making app purchases from Amazon.
I could be wrong, it happened once before.
Reply
#12
I'm really not sure why the update isn't showing up through Amazon. Their review process is pretty quick now, so I don't think that was holding it up. Did you manage to get the update installed on all your devices using the side-load approach?
Reply
#13
I haven't completely updated the rogue tablets after getting past the issue of the companion app not wanting to speak with them.
Everything is working well for the time being.

The Acer is getting an update notification, but the update fails...probably because the 'update' is for a version that is older than the one installed.
I could be wrong, it happened once before.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
3 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.