• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.4.7 is fubar
#1
Just updated to 1.4.7 and seems to have been a pretty fatal mistake. All menus are broken that either appear to do nothing (at least not visible anyway) or mysteriously are gone altogether and need to reboot to have them return.

The pic was trying to open the stacked 3 dot menu pic on Google Drive

I'm still able to build a set (albeit tedious since I can't employ any filtering) and the set displays fine. The menuing just seems to be totally whacked out.

I'm hoping it might be some sort of configuration issue. Is there a way to reset the config and not lose the DB?

Tablet is a Samsung Note 10.1 (GT-N8013)
running Android 4.1.2 (kernel 3.0.31-813049)



Thanks in advance.
Samsung Note 10.1 GT-N8013ZW / AirTurn BT-105
Reply
#2
You are now the second user to have experienced this issue. I'm really baffled by it as I didn't really change very much code between version 1.4.6 and 1.4.7. I certainly didn't modify any code related to the action bar/menus. One thing I did was update some of the support libraries I use from Google. I am going to try running my app on Android 4.1 to see if somehow the problem is related to the Android OS version.

For reference, the other user has a Galaxy Note 10.1 (2014) edition, GT-N8010 running Android 4.1.2.

Thanks,
Mike
Reply
#3
Well I didn't encounter any problems using an Android 4.1. emulator. I'm going to try installing on all of my devices to see if any of them exhibit the problems you are describing.

The only way you can reinstall without losing data is if you've created a library backup (Settings->Backup and Restore->Backup Library). If you are able to get to that and create a backup file on your tablet, then you could try reinstalling.

Mike
Reply
#4
FWIW, no problems on 4.4.2 and 4.4.4.
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (non-MSPRo, backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply
#5
Every device I've tried so far works, so I'm not sure what to do about this. I'll be curious to hear if a reinstall fixes it.
Reply
#6
Also from my side: no problems so far
first language: German
Acer A1-830, Android 4.4.2 - HP x2 210 G2 Detachable, Win 10 2004
www.moonlightcrisis.de - www.basdjo.de - www.frankenbaend.de


Reply
#7
(05-18-2016, 03:40 PM)Zuberman Wrote: You are now the second user to have experienced this issue.  I'm really baffled by it as I didn't really change very much code between version 1.4.6 and 1.4.7. I certainly didn't modify any code related to the action bar/menus.  One thing I did was update some of the support libraries I use from Google. I am going to try running my app on Android 4.1 to see if somehow the problem is related to the Android OS version.

For reference, the other user has a Galaxy Note 10.1 (2014) edition, GT-N8010 running Android 4.1.2.

Thanks,
Mike

I don't apply every update for reasons such as these. If it works and there's not something I need I usually pass. So I have no idea what version I came from.

I probably won't get to re-installing etc until the week of June 8th. I'll keep you posted.
Samsung Note 10.1 GT-N8013ZW / AirTurn BT-105
Reply
#8
I'm trying to find someone with a Galaxy Note tablet that is willing to test a few different APKs (these will just install over the current version) . If you want to give this a shot to see which one fixes the problem, send me an email at mike@zubersoft.com.

Thanks,
Mike
Reply
#9
I have a GT-N8010 running 4.4.4 (Omni). But I do not have the problem so I wonder if there's anything I can do to help.
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (non-MSPRo, backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply
#10
As far as I can tell, the problem only occurs on that tablet when running the stock 4.1.2, so I don't think there is anything you can do to help. Thank you for the offer though. I changed very little that could cause this kind of problem between 1.4.6 and 1.4.7, so I'm rolling back one feature at a time, and a user is helping me test each build to see if it has any impact. Hopefully soon I'll be able to figure out what change is responsible.

Mike
Reply
#11
Add another user with this issue to the list, Mike! GT-N8013, Android 4.1.2. Black screen with a few items on it, but essentially unusable menus. I am able to edit sets via Companion, though, so that's good. But that won't help me during a gig, etc.

[Image: 89cf0290-4031-41cd-9268-c54a9f8dd985_zpsc1sslw8p.jpg]
Reply
#12
I would have gladly taken this as an opportunity to get a new tablet, but Samsung won't make me a new Note yet! Tongue
(Even the Note Pro is getting old and likely won't be seeing updates, so I'm hoping for something new.)
Reply
#13
(05-19-2016, 02:57 PM)Zuberman Wrote: I'm trying to find someone with a Galaxy Note tablet that is willing to test a few different APKs (these will just install over the current version) . If you want to give this a shot to see which one fixes the problem, send me an email at mike@zubersoft.com.

Thanks,
Mike

Just sent you a note. I forgot I can use my wife's tablet which is the same as mine as she doesn't need MSP for a couple of weeks.

I'm in the process of upgrading hers from 1.4.6 to 1.4.7 and verify that she has the problem too.
Samsung Note 10.1 GT-N8013ZW / AirTurn BT-105
Reply
#14
I did release version 1.4.8 with a fix for this issue. Several users reported success after installing a build that removed Samsung multi-window support, so I'm hoping it will work for everyone.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.