• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Add warning before importing from incompatible version
#1
I am the 'Mobilesheets Master' in our family. Today I wanted to sync my database with the other ones by exporting it and importing it to the other devices.
It worked without complaint, but then Mobilesheets stopped without additional info.
It took some time until I realized that my exported version was 4.0.10, but the version where the (faulty) import ocurred was 4.0.2, I think.
So the database format seemed to be incompatible.
It would be great if there was aconsistence check before the import so that an existing database would not be overwritten if the versions did not match.
Plus a good error message would be great...
Reply
#2
Importing old databases into new versions is supported. Importing new databases into old versions may or may not be, depending on how old the version is. There is nothing I can do to add an incompatibility message to old versions of software, as they would have to be updated for this to happen (thereby making the change unnecessary). I'll add some code to ensure that if the version number in the backup file grows larger than what is currently known in a given release, it will flag it as incompatible. Thanks for the suggestion.
Reply
#3
Great, thanks!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.