• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mike - Yamaha MD-BT01 Bluetooth Midi?
#9
I actually added two different MIDI over bluetooth libraries. Once supports Android 4.3+, so that is the default. That library, like the current library for MIDI, automatically connects to any device it detects over bluetooth. By contrast, the Google MIDI library only supports Android 6.0+, but it allows you to pick and choose which devices to connect to. For most users, the automatic connection is probably just fine and they will have no need for the Google MIDI library. It's there as an option for users who want that capability (along with port based filtering for commands) or as an alternative just in case the default library doesn't work well on a specific device for some reason. The Google MIDI library is the only option for Chrome OS devices, for example, because Google doesn't allow MIDI connections over USB using the approach used by the default library. I also added a "Superpowered" MIDI library which offers the highest level of performance over USB, but restricts connections to class-compliant MIDI devices.

So you'll be fine using Android 5.0. If you want access to the Google MIDI library, you could consider updating, but I should mention that not every device on Android 6.0 can use Google's MIDI library. Support has to be included from the manufacturer of the device with the OS variant they release. My Nexus 10 uses a custom ROM, for example, and it can't access Google's MIDI library because the ROM doesn't have support for it.

Mike
Reply


Messages In This Thread
RE: Mike - Yamaha MD-BT01 Bluetooth Midi? - by Zubersoft - 02-08-2019, 02:12 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.