• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Creating network for tablets to join for Master/Slave
#16
Doing some research, I've found that the option to turn off "Avoid poor connections" within Android 5 and 6 are gone.

I'm still having issues but if I can get the tablets to notify me that Internet connection is poor, I can then press "more option" and force it to stay connected to said network.

Other than that, there's no options anywhere in Android 5 nor 6 to stay connected to networks which have no internet connection.

Poor decisions on Google's behalf, IMO.

If anyone has a workaround, I'd love to hear it!
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#17
That's definitely news to me... but it makes sense that I've never seen it, because I've only ever tested with my cell phone as a hotspot which has internet. I'm sorry that you are exploring new territory here and I'm not able to help much.  Very poor decision by Google to implement the WiFi that way. I will have to research that some more.

Thanks,
Mike
Reply
#18
I've been googling for more information on this, and many people have encountered this problem. There are a lot of interesting suggestions, especially for rooted devices, but this one seemed to be an easy one to try without root:

https://android.stackexchange.com/questi...o-internet

You can just assign a static IP and such to the device to avoid using DHCP. I'm curious if that will take care of the problem...

Mike
Reply
#19
I will take a look at that link. 


Someone suggested this app:

https://play.google.com/store/apps/detai...keeper.pro

It apparently keeps the connection to a network that has no internet.

I installed it late last night but haven't been able to test. Will report back.
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#20
(12-11-2017, 04:08 PM)dallaskruse Wrote: I had a gig on Friday, as I said ... the tablets were literally within 10 feet (clear signal path) of the router and they wouldn't stay connected to the Group.  I ran them in Bluetooth and had no problems.

I was saying that from the day 1 requesting this feature that in todays world of hundreds of WiFi networks people will have problems with interference.
Stick with Bluetooth.
Reply
#21
This has nothing to do with interference, as per the previous thread entries.
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#22
Update:

I installed "Best WiFi Keeper PRO". 
Apparently with my version of Android, there's no way to toggle on/off the option to drop a Wifi network if there's no internet. 

When there's no internet, Android will ditch that network and look for others...hence the tablets disconnecting from the group.

I installed this App and I think it forces the tablet to stay connected to the current Wifi network.

I will power on the tablets and it takes a good 5-10mins for them to settle in and see the Group I created within MSP ... but I had a fairly large gig with 8 tablets running and the Master/Slave running with Wifi worked.



I will tell the players that they're in charge of page turns within a song but I will control bringing up the next tune.

Reason being, obviously everyone is reading a different chart (drums, bass, guitar, horns, piano, etc) and some songs have 2 pages in the piano part while the drum part has 1 page.
Page turning gets tricky within the Master/Slave feature so I allow the musician to turn their own page(s).
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#23
Hi guys,

I'm encountering the same issues with my 3 Android devices and I'm a little sad about that:

Trying to connect 3 devices via Wifi works good if the Wifi has internet.
The connection seems to be stable. But Mike has tested this, so no surprise.
That's home, but not the a gig, where I carry some FritzBox with no internet connection.

The FritzBox with no internet connects well to my Android 4.4.4 and to 5.1.1 (I'm using 2 Hannspree 13", one old 4core and the newer 8core.
(The connection is not really stable, but sometimes stays healthy for more than an hour.)

But then my guys have the Trekstor 13" with Android 6 and here we got NO connection at all without internet present.

That's the reason why I haven't used this feature yet, although I was waiting fror it badly.

Bluetooth disconnects, too, unstable.
We all want to play our instrument, so this has to be rock solid to be of any use.

Mike, maybe there's the possibility to have the ad hoc wifi net of one machine running MSP providing the wifi net.
This would save us to carry a FritzBox or have our phone to be the hotspot.
Perhaps then you could find a way for that ad hoc to pretend it has an internet connection.
That way the tablets of the band members don't have to be modified.
A workaround on every tablet my band members bring on, is not realistic.

Thanx again for the great developer work,

Kai
Reply
#24
@dellaskruse

Did you have to install "Best WiFi Keeper PRO" on EVERY tablet?

Cheers,
Kai
Reply
#25
Found a workaround:

We can disable the setting

captive_portal_detection_enabled

of every device in adb Terminal.

Start Terminal, connect the Android 6 device

type the adb command
adb settings put global captive_portal_detection_enabled 0

press RETURN
Reboot your Android.

My impression is, after I did this, MSP on Android 6 connects very nicely and stable to my FritzBox WITHOUT internet connection.

If I experience bad things, I'll let you know.



In case you wanna undo this step:
Start Terminal, connect the Android 6 device

type the adb command
adb settings put global captive_portal_detection_enabled 0

press RETURN
Reboot your Android.
Reply
#26
Mike, do you think you could implement to have the

captive_portal_detection_enabled = FALSE

during MSP is running?

That aproach looks great to me Smile

Cheers,
Kai
Reply
#27
After some testing I can report:
No bad things happened, works great and hopefully this is gonna be automatic in a future update of MSP.

For the ones being interested my steps a little more clean:


/* have adb installed on your computer
https://www.xda-developers.com/install-a...cos-linux/

/* Connect Android with data cable
/* open Terminal app
/* now type this:

adb shell

/* press Return
/* you'll see the adb address of your Android device instead of theUser$
/* now type of copy this:

settings put global captive_portal_detection_enabled 0

/* press Return
/* you'll see not much, but you can check the status, 1 or 0 by typing this:

settings get global captive_portal_detection_enabled

/* now REBOOT your device: voila.


/* since your wifi now doesn't notice any more if there is internet or not, you might want to set this back to normal one day:
/* open Terminal app
/* type this:

adb shell

/* press Return
/* now type this:

settings put global captive_portal_detection_enabled 1

/* press Return
/* Back turned on to be picky about if there is wifi or not.
Reply
#28
If you are using ADB to set that value, that means it's most likely a protected setting in the OS that an application wouldn't be able to change without root access.  There is no API in Android for doing something like that. I just verified this - https://stackoverflow.com/questions/3721...net-access

From that post:

Code:
public static final String
       CAPTIVE_PORTAL_DETECTION_ENABLED = "captive_portal_detection_enabled";
   ...
   MOVED_TO_GLOBAL.add(Settings.Global.CAPTIVE_PORTAL_DETECTION_ENABLED);
but throws" android.provider.Settings$SettingNotFoundException: captive_portal_detection_enabled when used explicitly and is not visible to android studio.

also, doing a settings list global does not contain the constant.

edit doing a adb shell settings put global captive_portal_detection_enabled 0 does seem to work, but this can not be done in the field when the router cycles power. this value seems to persist when the tablet cycles power. and now this value shows up in a settings list global. also, using the raw string: Settings.Global.getInt(getContentResolver(),"captive_portal_detection_enabled"); now returns 0.

edit: looks like setting it requires: android.permission.WRITE_SECURE_SETTINGS, but of course this fails when put into the manifest since we are not a system app.

edit: trying to exec the shell command throws: java.lang.SecurityException, so it looks like you need to issue the command from adb :(

So not only can MobileSheetsPro not do it, it seems like you'll need to do it through adb after every reboot...

Mike
Reply
#29
ooooofff.....

this is disconcerting to say the least.

I spent a few hours this morning researching. i downloaded Android SDK but don't know how to Root my tablets to add the captive_portal_detection_enabled = FALSE 

But, even if I did figure it out, as Mike is saying, every time you reboot your tablet, you gotta re-impliment this code. No bueno.

Any other workarounds?
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#30
Sorry I'm just getting to this.

yes, I did have Best Wifi Keeper on every device. I'm still have connectivity issues on Wifi without internet.
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.