• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Midi Start/Stop as triggers for actions
#1
Hi. Would it be possible to add Midi Start and Stop as a trigger for a Midi Action? Specifically when my BeatBuddy starts the rhythm, I'd like to be have the audio start playing a background pad.
Thanks
Reply
#2
Tim,

Can you verify for me that your BeatBuddy is actually sending a MIDI Start command? That would be represented as a single MIDI byte with a value of 0xFA (250 in decimal). The only reason I ask is that I think it's pretty rare for MIDI equipment to send that message. In fact, the library I'm using for MIDI doesn't even list that as a normal trigger (I'd have to look at the MIDI single byte value myself). Unfortunately, you can't use the MIDI listen dialog in MobileSheetsPro to listen for the single byte message command, as so many of those come in that I had to ignore those, but if you use an external MIDI monitor (lots of applications for this on a Windows PC), you can verify that a single byte with 0xFA is sent.

Thanks,
Mike
Reply
#3
I just looked at the beatbuddy documentation, and it does seem to send those commands. So I will go ahead and add support for triggering actions on those messages. 

Mike
Reply
#4
Thanks for implementing this but it doesn't seem to work. The interface asks for a channel number which is odd as Midi Start/Stop don't have channel numbers. Is this the problem?
When I do a Midi listen in the app Start and Stop don't show up, but I know they are being generated. 
Tim
Reply
#5
Something doesn't sound right there. When I go to Settings->MIDI Settings->MIDI Actions, and I tap the new MIDI command button, and then select MIDI Start, Continue, or Stop, I don't see a channel number indicator anywhere on the dialog. Are you trying to add the command to an individual song? I had assumed you wanted to add a MIDI action to play/pause audio when those commands are received.

Mike
Reply
#6
(05-13-2018, 03:41 PM)Zuberman Wrote: Something doesn't sound right there. When I go to Settings->MIDI Settings->MIDI Actions, and I tap the new MIDI command button, and then select MIDI Start, Continue, or Stop, I don't see a channel number indicator anywhere on the dialog. Are you trying to add the command to an individual song? I had assumed you wanted to add a MIDI action to play/pause audio when those commands are received.

Mike

Your assumption is correct, however when I go to Settings->MIDI Settings->MIDI Actions, and tap the new MIDI command button (+), and then select MIDI Start, Continue or Stop, there is also an option in the dialog for channel (see attached screen shot). Also the Listen option does not show the Start and Stop codes being received. I can see them when I connect the Midi to my PC, and run MidiOx. I'm running Android 4.4.2 and version 2.1.8 of MobileSheets Pro.


Attached Files Thumbnail(s)
   
Reply
#7
I didn't update the MIDi listen dialog to print start/stop commands. I can do that in the next update, but I'll only show them when listening for MIDI commands in the MIDI actions dialog, as I don't allow songs to be loaded when a MIDI start/continue/stop is received (that wouldn't really make sense).

I can't figure out why you are seeing the channel option. I think that must be related to why it's not working. Did you change any of the other default settings for MIDI under Settings->MIDI Settings? I've been trying to modify all those, but it hasn't made a difference yet. I never see the channel on my devices.

Thanks,
Mike
Reply
#8
I've played around a little more but still can't get it to work.
- I discovered that changes in the Midi settings menu aren't saved until you close the settings. If you change e.g. multiple channels, you won't see the effect until you close the Midi settings menu and then come back to it.
- If Multiple channels is not active, then I don't see a channel for any of the Midi messages. If it's active, I see it for all of them (including Start etc).
- If I add Midi Start when multiple channels is active, then no channel is displayed and it looks good. However, if I leave that screen, activate Multiple channels (and close the settings), and then come back to the Midi Action screen, it now shows the Midi Start with a channel number (the default one).
Thanks for trying to debug this and sorry that's turning out not to be so simple.
Tim
Reply
#9
Okay, that helps, thanks for clarifying. I can reproduce the channel display issue, and I'll work on getting that fixed. 

I think I've found the problem in the code that is stopping the trigger on MIDI start/continue/stop from working. If you'd like to test an early release that fixes this, email me at mike@zubersoft.com and I'll upload a build for you to test.

Thanks,
Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
3 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.