• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problems with cloud
#11
(09-21-2018, 12:56 AM)Zuberman Wrote: Those file paths look very wrong. They look as if they came from an Android backup but weren't properly fixed.  Did you upload your Android tablet library to this folder and are synchronizing to the Windows 10 version? Did you change the default storage location in the Android version? Your Android device is running version 2.3.8, correct?

Thanks,
Mike

MobileSheetPro is installed in my Android Tablet (2.3.8).
I synced my library on googledrive and then I tried to sync it back to my new windows 10 installation.
In Android preferences "Let MobileSheets Manage my files" is flagged.
Reply
#12
(09-21-2018, 01:11 AM)simonegiusti Wrote:
(09-21-2018, 12:56 AM)Zuberman Wrote: Those file paths look very wrong. They look as if they came from an Android backup but weren't properly fixed.  Did you upload your Android tablet library to this folder and are synchronizing to the Windows 10 version? Did you change the default storage location in the Android version? Your Android device is running version 2.3.8, correct?

Thanks,
Mike

MobileSheetPro is installed in my Android Tablet (2.3.8).
I synced my library on googledrive and then I tried to sync it back to my new windows 10 installation.
In Android preferences "Let MobileSheets Manage my files" is flagged.

any hints ???
Reply
#13
I'm going to do some testing to see if I can figure out what's going on. If you synchronized your library to Google Drive using version 2.3.8 (and not an earlier version), then hopefully I should be able to reproduce the problems you are seeing.

Mike
Reply
#14
(09-22-2018, 07:34 AM)Zuberman Wrote: I'm going to do some testing to see if I can figure out what's going on. If you synchronized your library to Google Drive using version 2.3.8 (and not an earlier version), then hopefully I should be able to reproduce the problems you are seeing.

Mike

Hello Mike ... any news for me ???

thanks
Reply
#15
I just tested uploading a library from my Android device and synchronizing that to my Windows 10 device (which had no library at all). I didn't encounter a single error of any kind and certainly did not see the kind of invalid paths I saw in the screenshot you provided. So this leads me to believe something is fundamentally wrong with the file paths in your library/database. I'm going to need you to share a library backup file with me (send a link to mike@zubersoft.com), or at the very least send me mobilesheets.db. If you want to copy the database file, you'll need to enable Settings->Storage->Expose Database, and then it will be found in your storage location. Without that, there will be no way for me to figure out why you are seeing those errors.

Thanks,
MIke
Reply
#16
Quick question: if you go to Settings->Storage in the Windows 10 version, what path is listed for the storage location?

Mike
Reply
#17
(10-02-2018, 12:30 PM)Zuberman Wrote: Quick question: if you go to Settings->Storage in the Windows 10 version, what path is listed for the storage location?

Mike

c:\users\simon\documents\MobileSheetsPro
Reply
#18
Simone provided a backup file for me, and it turns out all of the file paths in the database were very messed up, such as:

00. MEDLEY PRINCE/mnt\sdcard\Android\data\com.zubersoft.mobilesheetspro\files\00. MEDLEY PRINCE\00. MEDLEY PRINCE.pdf

when it should have just been

00. MEDLEY PRINCE/00. MEDLEY PRINCE.pdf

The fact that backslashes were in the paths used on Android is big red flag. I've fixed the backup file for Simone, but any other user that has invalid paths like that should contact me for support. You can verify this by long pressing a song to edit it, go to the files tab of the song editor, long press on the file to view the path, and ensure that there are no backward slashes.

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
3 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.