• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Capo directive not working properly on import
#1
Hello all

Firstly let me say I love the software and use it regularly. I find the ability to combine chordpro files in set lists with pdfs and also have the ability to annotate (all in one piece of software!) fantastic.

I mainly use chordpro. My issue is with chordpro files that I have created and added a capo directive to them. After importing the chords appear in the original key (not capo transposed), yet the capo box appears correctly. When I open the settings MSPro has correctly set the capo to the correct position on the slide. The workaround is to set the slider to 0 then back to the desired position. This then displays everything correctly with chords transposed for capo.

I haven't logged this issue before as the workaround is quick, but I've always had this issue. I'm logging now as I've had a few large projects recently where I'm batch importing and not checking each individual file. If I'm going to keep doing batch imports it would be nice for the capo issue to be fixed.

All help appreciated. Thanks again Mike for the brilliant software.

-James
Reply
#2
This is, in fact, desired behaviour as defined in the ChordPro standard.

For guitar players, a song in key C with capo on 2 means: put the capo on 2 and play a C chord (which will sound as a D chord).
If you want the song transposed relative to the capo, in the Text Settings just click on the eye symbol right of the capo slider.
(Your workaround of sliding the slider has the same effect as clicking on the eye to enable it.)

In the Settings > Text File Settings you can enable/disable "Modulate Capo Down" according to your desire.
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (non-MSPRo, backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply
#3
Thanks for the reply Johan.

Perhaps it's due to playing with too many keyboard players but I always like to think in the correct key, but occasionally (especially if singing as well) I need easier chords to play so use capo chords. Would there be a way to decide on this behaviour at a global level / import level?

I currently have the option of modulate capo down ticked as this does what I want it to do (gives me the correct key in the listing, but shows capo box and capo chords). If I untick this then the chords are completely wrong. Apologies if I'm not understanding the logic of it.
Reply
#4
I've found the solution!

I've edited the global text display setting to have the capo eye setting turned on. This way when I import a song that has already been formatted with capo metadata, the capo chords are displayed by default but the key remains correct (i.e. song in key F#, capo set as 4, chords appear as D, key remains F# in display in case anyone briefly asks what key we're in).

Also - thanks for all your work on Chordpro Johan. I've recently started getting more in depth with the meta tags and am also now using your windows GUI for creating my own sheets. Still getting my head around the config files though!
Social: @JamestheBFG
Web: www.jamesthebfg.com
Reply
#5
You're welcome! See you on the ChordPro list.
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (non-MSPRo, backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.