• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MobileSheetsPro Companion does not connect anymore
#1
MobileSheetsPro Companion does not connect anymore to tablet.
It used to work (weeks ago)

I updated all versions, which did not fix the problem.
- MobileSheetsPro Companion version 2.8.3 Windows 10
- MobileSheetsPro version 2.5.9 Android 5.1.1

Windows Firewall is open. I cannot figure out what is wrong.
Connection is attempting 4 times then the error message "Unable to connect to tablet  . . . . . .  . . make sure port 8888, 16568 and 16569 . . .  "

Also USB connection is not working (the USB connection is ok, I can browse files using the windows explorer)
I allowed MobileSheetsPro to connect in debug mode.

Please suggest what to do
Reply
#2
Hello,

If you encounter connection problems like this, there are only a few things you need to look at:

1) On the Windows 10 device running the companion application, go to the settings for your current network. One way of doing this is clicking the network icon in the taskbar at the bottom right corner, then click on "Change connection properties", and on the dialog showing the network settings for your current network, click "Private". If "Public" is selected, it can cause packets to be blocked
2) Next, go to Windows Firewall, click "Allow an app or feature through Windows Firewall" and make sure both private and public are checked for MobileSheetsPro Companion
3) If you still can't connect to your Android device after performing steps #1 and #2, then if you have anti-virus or firewall software running, you should try disabling them to see if they are interfering with the connection.
4) The last thing you should try is rebooting your router. This fixes connection problems frequently for users

Let me know if you still can't connect after performing those four steps. As a side node, you shouldn't be trying to use USB for any of this. Please stick to using WiFi on both the tablet and in the companion application. Getting USB to work is incredibly difficult as it involves getting proper drivers (the same kinds a software developer would use) so that you can use a backdoor to send raw data over USB. It's basically a hack that utilizes a development tool called adb that Google provides to send data between the companion application and tablet. I never recommend users try this unless they have a very specific reason to, as WiFi is much easier to use and is reliable.

Mike
Reply
#3
(04-13-2019, 06:53 PM)pietzoodsma Wrote: MobileSheetsPro Companion does not connect anymore to tablet.
It used to work (weeks ago)

I updated all versions, which did not fix the problem.
- MobileSheetsPro Companion version 2.8.3 Windows 10
- MobileSheetsPro version 2.5.9 Android 5.1.1

Windows Firewall is open. I cannot figure out what is wrong.
Connection is attempting 4 times then the error message "Unable to connect to tablet  . . . . . .  . . make sure port 8888, 16568 and 16569 . . .  "

Also USB connection is not working (the USB connection is ok, I can browse files using the windows explorer)
I allowed MobileSheetsPro to connect in debug mode.

Please suggest what to do
I've just joined the forum and this thread so don't know if you've got this sorted yet. I had this problem when I got a new Chromebook, trying to sync to the Companion. I got it to work by going  to Sync to PC,  manually enter the PC's IP address then it linked led up fine.
Reply
#4
I had a similar setup and after the update the companion app also failed here.

My Windows Defender Firewall had two entries for the companion, one for the older version and one for the new, both with "domain", "private" and "public" enabled. To be sure to access the right entry, I removed both, started the companion app again, enabled then just "domain" and "private" closed and started the app again. It did not discover the tablet, but the manual connection worked again. Puuhhh. Rolleyes Whatever happened to the discovery/autoconnect...

Initially, I installed the companion in a windows virtual machine. In the VM the automatic connect never worked, but the connection to MSP still was ok so it was my fallback as long as the new version did not work. However, initially I encountered many connection drops while filling my database (different locations in the appartment, with/without repeater). This was ny reason for installing the companion outside the VM. Now, at the same place in the appartment also the VM installation runs stable (of course, no relation to the update)...
BTW, many many thanks for MSP. Wink  You put so many helpful features into it - its very useful and efficient. Ok, minor things here and there but software evolves Angel
Reply
#5
I'm having the same issue. I have had to do the manual connect since switching to a chromebook but that was fine. The last month or so, it has stopped connecting and I get the 4 strikes and out! :-)  The only step I didn't do above is the rebooting of the router as everything else seems to be working fine. I turned off my firewall to see if that was the issue and it still failed to connect. I'm not sure how to get to the ports mentioned to see if they are correct.....could I get those steps too?  I have recently realized that my laptop is not been able to do the Windows 10 update for awhile, would this have something to do with the connectivity? 

Thanks for all the help! I use the companion ALLLLL the time!
Reply
#6
I finally got windows 10 to update but still not connecting. The app gives me an IP address that starts with 100, which it has never done before and has been doing since my connection issue started. I have rebooted the chromebook, I haven't changed anything in the setting for the app. I still don't know anything about the ports listed in the error message or in the instructions above. Could somebody help me with that?
Reply
#7
Have you tried doing Connection| Manual Wifi Connection in the Companion? (type in the address shown on the front of the tablet)

Geoff
Samsung Galaxy Tab A6
Reply
#8
What version are you running on the Chromebook? Another user reported that when he went to Android 10 on his Chromebook, it stopped being able to connect to the companion app. At the time, I wasn't able to update my Chromebook to use Android 10. It's possible I could do this now though if the update is available. I just want to first check what you are running.

Thanks,
Mike
Reply
#9
(12-11-2019, 02:35 AM)Geoff Bacon Wrote: Have you tried doing Connection| Manual Wifi Connection in the Companion? (type in the address shown on the front of the tablet)

Geoff
Yes, I do that every time as it doesn't auto connect anymore (hasn't since I moved from a Nexus to a Chrombook)
Reply
#10
(12-11-2019, 04:19 AM)Zubersoft Wrote: What version are you running on the Chromebook? Another user reported that when he went to Android 10 on his Chromebook, it stopped being able to connect to the companion app. At the time, I wasn't able to update my Chromebook to use Android 10. It's possible I could do this now though if the update is available. I just want to first check what you are running.

Thanks,
Mike
I will have to check, I do the updates when it tells me too. So maybe that is it??
it says version 78.03904.106 (?)
Reply
#11
The problem appears to be that the wrong IP address is shown on the "Connect to PC" screen on the Chromebook. If you tap on the Wifi symbol at the bottom right corner, then tap on the arrow next to the WiFi network you are connected to, then tap the "i" with a circle around it at the top right, you can view your real IP address. That is the address you need to use in the companion app to connect to the Chromebook. I will look into why that IP address is being displayed that starts with 100. 

Mike
Reply
#12
Looks like I'm out of luck when it comes to ChromeOS devices. They are hidden behind an internal firewall, so the address I'm allowed to look up is the internal one. There is absolutely no way for me to retrieve the IP address of the device on the network from the Android code. I also can't determine if I'm running on a Chromebook, so I can't do anything differently in that case (although I could detect when the address is 100.X.X.X and replace it with "Unknown" or something like that). At least one I switch to using DNS-SD, the automatic connection with the companion app will work again.

Mike
Reply
#13
(12-12-2019, 06:27 AM)Zubersoft Wrote: The problem appears to be that the wrong IP address is shown on the "Connect to PC" screen on the Chromebook. If you tap on the Wifi symbol at the bottom right corner, then tap on the arrow next to the WiFi network you are connected to, then tap the "i" with a circle around it at the top right, you can view your real IP address. That is the address you need to use in the companion app to connect to the Chromebook. I will look into why that IP address is being displayed that starts with 100. 

Mike
Mike, this worked! Thanks so much! I will check that from now on to make sure it connects. 
You are the best!!
Reply
#14
I have also just experienced a failure of MS Pro (2.8.8) on an Acer tablet (Android 7.0) to connect to the Companion app on my PC (Windows 10).  It's been working fine until today.  I've tried looking into it as per the guidance above. but I can't get the PC to recognise the tablet.   Has some feature been changed very recently?  As a non-techie, I rely on this set-up to work smoothly and am easily confused by complicated troubleshooting instructions.

Another thing . .  I was going to open this as a new thread rather than tack it onto an earlier post. The 'Help' page says there is a 'New Thread ' button at the top and bottom of the relevant forum page, but I couldn't see it.
Reply
#15
Have you tried doing a "Connection | Manual Wifi Connect" ? (just type in the address shown on the tablet)

I use this on the odd occasion that the automatic connection dialog doesn't show (actually, it is nearly every time now but that it due to my BT5 router!)

Geoff
Samsung Galaxy Tab A6
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.