• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't import local file
Recently the import local file function started hanging up after a file is selected and the import dialog starts, with the swirling hourglass going for minutes (indefinitely) instead of just seconds. The Cancel function is inactive so I have to close the database to quit the process. I tried restoring a previous backup database and Import works fine.  The current copy has about 25 additional songs vs the backup copy.

Is there some way to fix a "corrupted" database that won't allow import,  and/or is there a way to export a simple text list of songs with an associated last update date so I can compare old vs. new databases to ID the new songs that would need to be recreated or those to be updated?

This problem has been occurring on a MS Surface Book running Win 10 Pro #1809 and MS Version 2.6.5 for a week now.
Can you update to version 2.6.8 and verify that problem is still occurring with the latest update? I just want to rule out issues that may have been fixed. To update, open the Microsoft Store, search for MobileSheets and tap the button to update.

If it is a database problem, then fixing a corrupted database would depend upon the nature of the problem. You can go to the Songs tab and sort by "Date Created" to see when the songs were added to the library. That might allow you to figure out which songs are the most recent ones. If you want to generate a list of songs with the update date displayed, you'll need to do a few things:

1) Add all of the songs to a setlist. This can be done by creating a new setlist and tapping the icon with two arrows.
2) Go to Settings->Library Settings->Generate Song Title Format and add %CREATION_DATE% where you want it to show up next to the title.
3) Long press the setlist on the setlists tab, tap the three dots at the top right and then tap on "Generate Song List".

If you go to C:\Users\<your username>\AppData\Local\Packages\41730Zubersoft.MobileSheets_ys1c8ct2g6ypr\LocalState and send mobilesheets.db to mike@zubersoft.com, I can try testing with your database file.

Thanks for the quick response Mike!

I updated to 2.6.8 via the MS Store but still have the same negative results.
I will upload db file and an msb file of the database giving me problems.

Best Regards
Mike - one follow up question on generating a song list once I've completed steps 1 & 2.

In step 3 as listed, do I select the Setlist Tab to display all setlists, then select the ALL SONGS setlist?
Long pressing the Setlist Tab doesn't do anything apparent.

Tapping on the 3 dots under the Setlist tab, I don't find any "Generate Song List" option.
Only Import, Add Songs, Remove Songs, or Create Setlist or Collection.
Under Settings/Library Settings I see "Generate Song List Format" but that's it.

So what am I missing?
Mike -
My bad - I see now I long press the - ALL SONGS setlist - and it becomes highlighted and a new menu appears.
Got it.
---- CLIPPED -----
From: Michael Zuber <mike@zubersoft.com>
Sent: Friday, June 28, 2019 9:21:22 AM
To: J Leggett
Subject: Re: MobileSheets Support Request - Can't import local file

Hello John,
I loaded MobileSheets using your database and everything came up fine. I then went to Import->Local File, picked a .txt file on my C: drive, and imported it. I didn't encounter any problems and the file imported without issue. So the next thing I would like you to do is to zip up all the xml files in the same directory as mobilesheets.db and send those to me. Then I can test using your same exact settings and see if maybe it's related to something like the "Auto-Size Font" setting under Settings->Text File Setttings. You could try turning that off and see if that is part of the problem. If so, I'll need to figure out how to reproduce the problem on my machine.
On Sat, Jun 29, 2019 at 9:54 AM J Leggett  wrote:
I tried disabling the Auto Text feature as you suggested and the Import Local File now works flawlessly!  Thanks for that tip.  If you’d still want the bundle of files sent to you to reproduce the issue, let me know. Otherwise, I’m a happy camper.
Thanks again for the support and a great app.
John L.
 Sat 6/29/2019 11:39 AM


I think I'm good to go now as I located and fixed the problem. The fix will be included with the next update.

Best regards,
Sun, April 26, 2020

I hate to bring up this subject again but I updated to V2.9.5 and the import problem is back.  Import of local txt file shuts down the app after identifying file to import.  I never even get to click "OK" before the hourglass spins and then the app closes.

So I backed up the db, uninstalled and reinstalled v 2.9.5 then restored the db. Turned off the Auto-Size Font Text File Setting which fixed the problem before, but local txt file import still crashes.  So I Reset All Settings to default using Other Settings. Now local txt file import works.

Restored db a second time including settings; problem still persists.

Any suggestions as to which settings may be causing the issue this time, so that I don't lose all my settings or have to recreate them?
Best Regards,
John L.
Hello John,

Can you please send one of the files that isn't importing correctly to mike@zubersoft.com? I can run some tests - if I'm able to reproduce the problem, I'll get a fix in place ASAP. It would also help to have either your backup file or all of the xml files from the directoy I mentioned before. That way I can run with the same settings as you.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2022 MyBB Group.