• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metronome won't toggle off with footswitch.
#1
Windows 10 Home, Version 1903 OS build 18362.295
Mobilesheets 2.6.9 ( I think this update came a few days ago)

I've been using a couple BOSS FS-6 footswitches hooked to an XKeys three key external keyboard device that interfaces to my Windows 10 PC via USB.  I use two of the pedals to change pages (works great).  I set the page turning to the "left" and "right" keys and the third pedal is used to toggle the metronome on and off (pedal set to the "down" key).  This has all worked well for several months.  But yesterday (7/20/2019) the pedal for the metronome has a couple problems.  1)  It turns the metronome on but the blue beat lights do not show on the screen.  and 2) Upon the second press it no loinger turns the metronome back off like it used to before yesterday.

I have tested the pedals by creating a text document and moving the cursor around and all the pedals do the appropriate action.

Has something changed in Mobile Sheets to cause the metronome toggle to stop working?  Manually turning the metronome on and off works fine.

Thanks,
Keith

btw, I really like Mobilesheets and recommend it to everyone.  I play about 4 gigs per week and really couldn't do it without this software.
Reply
#2
Hello Keith,

I just set up a quick test where I used the down key to trigger the metronone to start/stop, and I can't seem to reproduce what you are describing. I used pedal 3 for this, as I assumed that's what you did as well. In the metronome settings, I tested audio + visual and audio only. Is your metronome set to audio only by chance? That would explain #1. #2 I'm struggling to understand though. Do you have any other software running on the device that would use WASAPI audio? That would cause a conflict with MobileSheets. 

As for your question, the only thing that changed in the metronome with version 2.6.9 was the fix for using a non-default Beat Subdivision such as eighth notes. There were also some minor optimizations but they wouldn't cause the kinds of issues you are describing.

Thanks,
Mike
Reply
#3
(08-22-2019, 03:13 PM)Zubersoft Wrote: Hello Keith,

I just set up a quick test where I used the down key to trigger the metronone to start/stop, and I can't seem to reproduce what you are describing. I used pedal 3 for this, as I assumed that's what you did as well. In the metronome settings, I tested audio + visual and audio only. Is your metronome set to audio only by chance? That would explain #1. #2 I'm struggling to understand though. Do you have any other software running on the device that would use WASAPI audio? That would cause a conflict with MobileSheets. 

As for your question, the only thing that changed in the metronome with version 2.6.9 was the fix for using a non-default Beat Subdivision such as eighth notes. There were also some minor optimizations but they wouldn't cause the kinds of issues you are describing.

Thanks,
Mike
Thanks Mike for looking into this,

My metronome is set to audio + visual.  When I start and stop it manually it works fine.  But when I start it via the USB foot switch, only the audio starts.  Foot switch will not stop it.  To stop it I have to go to the menu where the metronome icon is not lit up and press the metronome icon which lights up the  icon but does not stop the metronome.  Then when I press the lit up metronome icon, it stops the audio and the icon becomes unlit.

Some upgrades to Windows 10 went on about the same time the last updates to Mobilesheets were applied.  Something in these updates may have caused this because it was working fine before.

When I get home I will make a little movie and send it so you can see it.

Thanks,

 Keith
 bassist 
 mixednutsmusic.org
Reply
#4
Video 
Here is the movie.
https://drive.google.com/file/d/1HicJwUj...sp=sharing
Reply
#5
Thanks for the video. It seems to me like what's happening is the down arrow is being triggered multiple times in a row in MobileSheets, and it's causing the metronome to both stop and then restart immediately. At least that's the only thing that comes to mind based upon the video. If you go to Settings->Touch & Pedal Settings->Pedal Actions, what is your pedal debounce set to? It definitely should not be disabled. Since you have access to a keyboard on the laptop, do you get the same behavior when pressing the down arrow on that keyboard? The processing in MobileSheets is exactly the same regardless of whether it came from a pedal or keyboard.

Thanks,
Mike
Reply
#6
I found the solution to my problem.  I had both Pedal 3 and Pedal 4 set to the "Down" key and both had the action "Start or Stop Metronome".  This used to work fine but stopped working about 10 days ago with the latest updates of Windows 10 and Mobilesheets (not sure which actually caused it since both got updated).

The solution was to change Pedal 4 to use a different key, "S" in my case.  This has no impact on me since I have no pedal 4.  I only have three pedals assigned to "left", "Right", and "Down".

By having Pedal 3 and Pedal 4 assigned different keys (even though both are for "Start or Stop Metronome") it all started working again.

Not sure if this is a bug, but you may want to add something to the manual so users don't assign the same key and action to more than one pedal.

Thanks,
keith
www.mixednutsmusic.org

P.S. I love Mobilesheets.  I've tried them all and it is the best.
Reply
#7
Nice job on figuring that out. Assigning the same pedal twice will definitely cause odd behavior. I may need to warn users about that if they assign the same action to multiple pedals. 

Thanks,
Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.