• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Auto re-connect of tablets fails (master-slave)
#9
I think a lot of this comes down to three things:

1) The devices that are used
2) The OS version those devices are running
3) The router that connects them

I've run many tests in the past where I put the tablets to sleep for 15 minutes or more and when I turn them back on, they are all connected without issue (They don't even need to reconnect, they are just connected as the OS didn't sever the connection in any way). I have a few more tablets I can throw into the mix now, so when I get a chance, I'll try connecting around 12 devices over WiFi, see if there are any connection issues over an hour or so, then try putting them to sleep and see if that breaks the connection. If I had to guess based on past tests, I don't think I'll encounter any problems. This is one of those problems that is very difficult to solve if you can't reproduce it yourself. For example, is the reconnection code failing because different IP addresses are being assigned when the tablets reconnect to the router? Is there something in the network stack itself on Android that behaves differently across devices and OS versions? Are there bugs in my code that only occur under very specific scenarios when connection quality is low and the TCP code is disconnecting/reconnecting rapidly? It's really hard to say. I'll keep trying to address this, but I'm just grasping at straws if I don't see the problem in my test environment.

Thanks,
Mike
Reply


Messages In This Thread
RE: Auto re-connect of tablets fails (master-slave) - by Zubersoft - 12-19-2019, 03:30 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2022 MyBB Group.