• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metronome audio not functioning
#1
I purchased the app after using the free trial. I recall that the metronome sounds were working before my purchase. I know the metronome is on because I've tried the various visual displays. I've also tried the two applicable playback modes ('Audio and Visual' and 'Audio Only') and cycled through all the sound options. I just tried a backup of my library, uninstall/reinstall, and restore but the sounds are still missing. I haven't been able to figure out if there are other settings I should be checking, besides that my tablet isn't muted (Surface Pro 7).
Reply
#2
Do you have any other applications running on the device that utilize WASAPI? It's possible the other application is taking exclusive control over the audio output through WASAPI which means MobileSheets won't have access to it. If that's not the issue, look at the Volume Mixer in Windows 10 and verify that MobileSheets is going out through the audio device that you are expecting it to. Have you rebooted your device yet to ensure it's not a weird issue that might be resolved with the audio driver being reset?

Mike
Reply
#3
MobileSheets isn't listed in the Volume Mixer window (https://i.imgur.com/zQFXkgI.png). My tablet has been rebooted several times since I first noticed this issue happening. I don't believe I have anything on the tablet that would monopolize WASAPI (I haven't installed any audio-related programs yet).
Reply
#4
A couple of questions:

1) I'm assuming that toggling any of the various settings in the metronome including the soung effect to use for the beats has no impact on the sound output, correct?
2) If you plug in headphones, do you hear the metronome through those?
3) What is the system volume set to? If you adjust the metronome volume, I'm assuming that changes nothing, correct?
4) Can you play audio through other applications without issue?
5) If you go to the Sound settings window in Windows 10, what output device is selected? What other choices do you have for output devices?
6) If you add an mp3 to your song in MobileSheets, can you play audio back and hear it?

Thanks,
Mike
Reply
#5
1) Correct, no impact when toggling the various settings (time signature, beat subdivision, sound fx, accent first beat)
2) Headphones made no difference. Also tested additional audio to make sure headphones were functioning
3) System volume was set to 36% while metronome was set at 100%. No effect when changing metronome volume
4) Yes (checked Spotify, Groove Music, a game on Steam, and YouTube)
5) The only option listed is "Speakers (Realtek High Definition Audio(SST))"

6) I loaded in an mp3 but get an error message when trying to play it while viewing the audio files editor: "Unable to load file <name of file>". The same message appeared when viewing the audio player. Then I clicked the 'edit' (pencil) icon in the audio player and tried to play the track again - now it's able to play the track AND the metronome is working! I opened another song without an mp3 attached and the metronome was still working. I'm not sure why clicking edit fixed it. I did exit and reopen the app and it was still working.
Reply
#6
Is Settings->Other Settings->Disable Audio Player set to "Always"? It appears there is a bug that is breaking the metronome in the Windows 10 version when the audio player is disabled. I'll look into getting that fixed.

Thanks,
Mike
Reply
#7
It had been. I was trying to get to the Audio Player while testing the mp3 and had to change that setting.
Reply
#8
The audio player and the metronome share the same audio engine in the Windows 10 version and I hadn't accounted for that in some of the code when it checks to see if the audio player is disabled. It will be fixed in the next update I release. You will have to leave the audio player enabled for the time being.

Thanks,
Mike
Reply
#9
That's fine. I'm just glad to have the metronome back. Thanks!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.