• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible to send Midi timecode to MainStage for tempo changes?
#1
Question 
I use MainStage when playing live. Is it possible to send midi timecode from MSP to MainStage so that when I pull up a song, MainStage will change it's internal tempo to the tempo of the current chart in MSP?
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#2
Yes, you can either use a smart button to start sending the MIDI time clock messages, or you can configure the song to start sending the messages when it's loaded. The tempo is based on the current tempo of the metronome. Let me know if you need any help setting up the MIDI command.

Mike
Reply
#3
I was able to set "Start Sending timing clock" and set it to "send on song load".

I am plugged into my MacBook Pro and the tablet is set to USB for MIDI mode.  Inside my Audio/Midi Setup within my MacBook, it sees the device as a Midi device.

The MacBook isn't receiving any midi messages from MSP. I have a midi monitor app on my MBP and it monitors any and all Midi messages. Nothing is coming in from my tablet.

What am I missing?
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#4
I downloaded a little Midi Keyboard App on my tablet and opened it up and enabled within the app to send Midi Messages through the Android USB Peripheral port and when I started playing, it was sending the midi messages (Note On/Off) and my MacBook was seeing all of it.

For some reason, MSP isn't sending Midi Messages out through the USB port.
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#5
If you want to use your tablet in "USB MIDI Mode" then you have to go to Settings->MIDI Settings->Configure MIDI Connections and switch to the Google MIDI library. The default MIDI library doesn't support virtual MIDI ports which is what happens when you enable MIDI mode in the USB connection settings. You'll need to check both options for whatever shows up for the input/output ports (you may need to uncheck the box at the bottom left that filters on MIDI devices to see the input/output ports). Then you should be able to connect through your MacBook.

I'm not going to go into too much detail, but normally the tablet acts as the host and the MIDI device is the one connecting to the host. You are flipping that around as the Macbook Pro is the host and it is trying to connect through USB to virtual ports exposed by the device. These are very different things which is why the default MIDI library doesn't work. 

Mike
Reply
#6
(01-16-2020, 12:27 PM)Zubersoft Wrote: If you want to use your tablet in "USB MIDI Mode" then you have to go to Settings->MIDI Settings->Configure MIDI Connections and switch to the Google MIDI library. The default MIDI library doesn't support virtual MIDI ports which is what happens when you enable MIDI mode in the USB connection settings. You'll need to check both options for whatever shows up for the input/output ports (you may need to uncheck the box at the bottom left that filters on MIDI devices to see the input/output ports). Then you should be able to connect through your MacBook.

I'm not going to go into too much detail, but normally the tablet acts as the host and the MIDI device is the one connecting to the host. You are flipping that around as the Macbook Pro is the host and it is trying to connect through USB to virtual ports exposed by the device. These are very different things which is why the default MIDI library doesn't work. 

Mike
Mike

that did it.

Is there a way to Default to have all songs send MTC when either the song loads or when I start the Metronome?
Or do I have to go to each song and EDIT SONG and setup an EDIT MIDI command?

I use MSP metronome for all my gigs in conjunction with MainStage ... this ability to change my tempo within MainStage is awesome and wondering if I can globally set each song to send MTC when either a song loads or the Metronome starts.
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#7
If you trigger the MIDI timing clock to be sent, it will never stop being sent until you trigger a MIDI message in MobileSheetsPro to stop it. So if you have one song that sends the message, you use a MIDI action to trigger the sending, or you use a smart button to trigger the sending, it will keep being sent as you switch songs. If there is a MIDI command you can send to MobileSheets to start triggering the timing clock, that might work well, so set up a MIDI action for that if so.

Mike
Reply
#8
Perhaps I'm misunderstanding ... I setup MTC to start on song load for the first song of the set.

When I switch to the next song, MSP isn't sending that next song's (song #2) tempo. It's still sending song #1's MTC/Tempo.
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#9
If you are seeing that behavior, that's a bug that I will have to fix. When the song changes, it should update the metronome tempo which should alter how fast the miding timing clock messages are sent.

Mike
Reply
#10
(01-17-2020, 11:25 AM)Zubersoft Wrote: If you are seeing that behavior, that's a bug that I will have to fix. When the song changes, it should update the metronome tempo which should alter how fast the miding timing clock messages are sent.

Mike

OK. Thank you.

When I switch songs, the tempo does not update to the current songs tempo ... so it must be a bug?

Thanks for the clarification.
12 tablets (Insignia, ONN, Dragon Touch). Ranging from Android 5 to 9.
Reply
#11
It looks like I was wrong. Looking back through the code, I explicitly stop the MIDI timing clock message when the song is changed. I'll have to consider which behavior I think is best. I'd love feedback from as many users as possible on this. If I left the MIDI timing clock going when switching songs and the user wanted to stop it, they would then need to add a MIDI message to stop it, which is also tedious.

Thanks,
Mike
Reply
#12
Hi
Just to share my little experience here.
I use MSP MIDI features to control a Line6 Helix multi-effects.
For each song, I have set a metronome value and programmed a MIDI tempo synchronization message (amongst other messages) when loaded.
By doing so, and as expected, when I switch song, tempo on Helix is changed and synchronized to the new value.
 
I have some issue though: at some point when going thru a set of songs, the MIDI link is lost and I have to disconnect the usb cable and reconnect to make it work again.
This happens quite randomly, but I suspect it may be caused by the clock message : if it’s continuous, it could “saturate” the line somehow?...
 
Could also be some hardware issue (tablet replaced, same thing. Maybe the USB cable or adapter?)
Or some Helix susceptibility (I already use some MIDI pause messages in-between MIDI messages to force a step-by-step acknowledgement)
I will investigate deeper, this random occurrence not helping…
Do you know any Android app to monitor in/out MIDI messages?
 
Cheers
Reply
#13
If you have MIDI echo enabled, that can definitely cause saturation problems. If not, the MIDI clock will definitely push out a ton of messages, but it shouldn't cause disconnections to occur. If you go to Settings->MIDI settings->Configure MIDI Connections, which library are you currently using? If you haven't tried Google's MIDI library yet, you could give that one a try to see if it prevents the disconnects you are seeing.

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.