• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to prevent bluetooth pedals from sleeping on Windows 10
#1
I just assisted a user with figuring out why his AirTurn pedal was becoming unreliable on his Surface Pro 7, and I wanted to share the information here. If you find that your Windows 10 device is not communicating with a pedal reliably, try the following:

1) After pairing the pedal in Windows 10, search for "Device Manager" in the Windows taskbar and load the Device Manager
2) Go to "Human Interface Devices", and you should see entries for "Bluetooth HID Device". Double-tap these entries, go to the "Power Management" tab, and uncheck the option to "Allow the computer to turn off the device to save power"
3) Next, follow the directions mentioned here (https://www.airturn.com/support/how-to/h...ws-machine) to set the Wireless Adapter Settings in the advanced power management window of Windows 10 to "Maximum Performance". This will stop the bluetooth connection from sleeping so that the pedal is more responsive.
4) If you find that you can't see the "Wireless Adapter Settings" option, this is due to something in Windows 10 called "Connected Standby". This will need to be disabled in the registry. You can follow the directions in this article (https://www.lovemysurface.net/windows-10...r-surface/) which says to do the following:
  • Start regedit in Windows 10 (search for it using the Windows taskbar and then load it)
  • Browse to the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power
  • Change CSEnabled from 1 to 0
  • Reboot your device
After doing that, you will now be able to access the advanced power management settings and you can change the Wireless Adapter Settings to "Maximum Performance".

Hopefully this will help others as it did result in my AirTurn pedal becoming much more reliable and responsive on my Surface Pro 4 (at the expense of some battery power).

Mike

UPDATE:
In the case of the user I helped, it turned out he did not have the pedal in mode 3. As mentioned in the AirTurn FAQ when asked "Which mode should my pedal be in?":

For current models BT200, BT200S, and PEDpro, use Mode 2 for iOS/Android, Mode 3 for Mac/PC, Mode 7 for MIDI, Mode 1 for App-Direct. For other models or uses, refer to your models manual: manual.airturn.com”

Upon switching to mode 3, his pedal started working properly. I should also mention that some users have to use mode 3 for Android as well.
Reply
#2
That's why I always felt Windows is such a overkill (and power inefficient) as it uses so many resources for running simple task such as running MS.

I started on Windows 95 so I can easily follow your instructions but for a person with little PC experience (outside of browsing/emailing) you might mention they are editing registry at their own risk.
Reply
#3
Surface Pros are not known for their ability to switch between apps quickly.

Before coming across this post, I determined that part of my problem could be attributed to my antivirus software: Norton.  Norton has a real time component. When I suspended Norton Auto Protect and SONAR for a period for time, the occurrences of dropped communications was significantly reduced.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.