• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Encoding in .CSV import
#1
I've had problems with encoding in .CSV files that I resolved by removing the BOM (Byte Order Mark) from the beginning of the file. But now I notice that several characters are not appearing in the song metadata. A frequent example is the en-dash (the technically proper divider, print-wise, between number ranges that my database uses to show the birth-death years of composers and lyricists--vs. the hyphen), which displays in MSP as the diamond with the ? in it.

I haven't made an exhaustive search of what other characters aren't displayed properly (I only care about French, Spanish, Italian, and German diacritics, and I see that at least the French é with accent aigu  is displayed), but is there some general rule of what encoding I must ensure that I'm feeding to MSP in order to have those characters displayed? I'd like to have this nailed before I import thousands of songs. I picked whatever encoding would coax my exporting database NOT to output a BOM, so I could get everything working. But, as I believe Mike has already decided to strip BOMs in future updates, I'd like for that future to know what encoding choice will give me the en dash plus the Euro diacriticals and have them displayed properly in MSP.

Thanks. - Kevin
Reply
#2
As of version 2.9.2 which has been available for awhile, the BOM is stripped automatically. So you no longer have to deal with that. I'm not sure why the en-dash is not showing up for you - it depends both on the encoding that is being selected by MobileSheetsPro in addition to the font that is being used to display the characters. If the font lacks support for a given character, then it can't be shown. Likewise, if the encoding doesn't support that character, it will show up as a diamond. If you send me a file you want me to look at, I can certainly do that. You could go back to having the BOM at the beginning if that worked properly for you.

In general, UTF-8 should handle most characters. As a side note, how did you switch the encoding to remove the BOM? Did you use an editor like Notepad++ which lets you switch file encodings? That would have ensured it was handled correctly.

Mike
Reply
#3
I haven't received an alert to update to 2.9.2. Isn't that supposed to happen automatically in the Win10 version? Is there some setting I screwed up? I thought I was using the latest version.

As to how I removed the BOM, I simply selected an encoding choice from my database that produced no BOM (I checked with a hex editor). That's the only way I could get .CSV import to work. I'll go back and find my earlier posts (or maybe e-mails?) where I identified exactly what encoding I chose--can't do it right this minute.
Reply
#4
That's completely my fault - somehow I didn't update the FastSpring installer and latest version file correctly. If you close and restart the app now, it should prompt you to update to version 2.9.2. Thanks for letting me know there was an issue.

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.