• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connect device over LAN
#1
I'm a long time MobileSheets user and I play with others who use it too.  We use "connect to device" a lot via wifi to sync page turns - which is great, as I can then use a foot pedal.  However, with Covid-19 we're now playing live in different locations - so we're not on the same wifi and out of bluetooth range.  Would be fantastic if we could connect a device remotely via the Internet - happy to open up ports and forward them etc as necessary.  Thanks!

--Andrew
Reply
#2
MobileSheets uses a TCP/IP connection to connect to other devices. If you use the "Direct Connect" option, you can specify any IP address you want in there. So what you'd have to do to connect to someone else on an entirely different network is specify the IP address used to connect their router or cable modem to the internet (you can find this by going to a site like https://whatismyipaddress.com/). On their end, they'd have to configure their router to allow these external connections, preferably just on the ports MobileSheets uses to connect. For the "Connect Tablets" feature, I use port 48000, so you'd need to allow that through the port forwarding in the router. 

I've never tested something like this before, so you'll have to let me know if it works.

Mike
Reply
#3
Thanks Mike - what protocol type do you use (e.g. TCP, UDP)?  Thanks.
Reply
#4
If I open up TCP and UDP port 48,000 incoming and forward this to the MobileSheets application I can't connect.  Is it possible others ports are involved in the dialogue?
Reply
#5
If you use the direct connect option, port 48000 is the only port involved. I'm only using TCP as it's a direct connection between devices. How did you go about setting up the port forwarding? I just want to review the changes you made in the router configuration.

Mike
Reply
#6
I use a Fritz!Box for the Internet router.  Under "Permit Access" I configured "Port Sharing" settings.  Specifically, I permitted access for TCP port 48,000 only on the PC running MobileSheets, and assigned the same port externally.  The Fritz!Box confirmed that the port was shared for this device.  I then set up an inbound firewall rule on the PC allowing TCP and all ports for the MobileSheets exe.  Then I used my public broadband address (which is static) as the address on a remote tablet attempting to connect using "direct connection".  After a time the tablet timed out with the message "unable to connect".
Reply
#7
Did you try pinging the IP addresses?
This uses different ports but would at least establish whether or not the devices are "visible" to each other

That is about all I can suggest.

Geoff
Samsung Galaxy Tab A6
Reply
#8
(04-06-2020, 09:21 PM)Geoff Bacon Wrote: Did you try pinging the IP addresses?
Thanks Geoff, but unfortunately the "ping" ports aren't enabled on the public interface for security reasons.  I have used this technique successfully to port forward other services, so it should work in principle.
Reply
#9
You could always use telnet to connect to the specific port you have opened up. Here's some details..

https://www.techwalla.com/articles/how-t...cific-port

HTH

Andy
Reply
#10
So I installed Microsoft Message Analyzer and monitored the traffic between PC and tablet with a direct connection active.  It's true the remote end point is connected via port 48000, but the local end point (the master) uses port 51854.  When I forwarded BOTH TCP ports everything worked.  In fact the page turns are as instant as when the tablet is connected via local wifi.  Hurrah!   Smile

Note - the Fritz!Box warned me that I could only have one port (or range) forwarded to a particular device at a time, but accepted the addition of a second in any case.
Reply
#11
I have no idea why port 51854 is being used for anything as that is not listed in my code anywhere. Great job on getting it to work though!

Mike
Reply
#12
You're welcome.  

BTW if anyone's interested the live services I've been using to play together with others are jamkazam (can be fiddly to get your audio gear working with it but really good if you do) and jamulus using a private server (really easy to setup but only one session per server - hence my private server which just runs on a Windows PC - you do need Asio audio drivers though, which are easily dealt with via Asio4All).
Reply
#13
If I understand correctly, the master is the "local" device. If so, then I'm rather surprised you needed to forward the port that was using to connect out to the remote devices. There shouldn't be any port forwarding going on when it makes a connection out. Maybe it is just that "unusual" ports are being blocked in general and adding the forwarding config unblocked it.

Anyway, good that you got it sorted. And I might have to investigate some of those "jamming" services. I'm missing playing with others.

Andy
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.