• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issue Connecting Roland f140 piano pedals
#1
I can't connect the pedals from my roland f140 to turn pages. Any idea how can I do it?
I am using win 10 professional on surface pro 7. The Bluetooth is on and the piano is paired with the surface pro, also the piano Bluetooth is on to allow apps to turn pages.
I also tried from the app settings to connect via midi actions, but it didn't send any information.

Please help. The app is on trial for now, but if I can make this work, then I will buy it.

Thanks!
Reply
#2
Take a look at this post: https://zubersoft.com/mobilesheets/forum...p?tid=6293

Can you confirm you have the device connected over bluetooth, and that you are receiving MIDI messages?

Mike
Reply
#3
The Bluetooth connection is on, because at midi devices the piano appears, but I don't receive any midi messages.
Reply
#4
Just to confirm, if you go to Settings->MIDI->Select MIDI Devices, you see your keyboard listed, you tapped on the input/output ports, it shows they are connected, but if you go to the MIDI listen dialog and you press the pedals, no messages are received? If so, that would indicate that the Roland F140 does not send MIDI messages for the pedals, so there is no way for MobileSheets to communicate with them that way. I'm not sure if Roland designed them to work with external applications.

Mike
Reply
#5
Yes, on midi devices in settings I see the piano and in midi listen dialog I don't receive anything  from keyboard or pedals. Also, something very strange.... When my piano is connected to a Bluetooth android app or android phone, it shows the Bluetooth sign on screen. Here, it doesn't appear at all. Also, when I click the connection button (like a phone) To manage device connections, it doesn't see the piano.

I've checked with roland and the f140 sends midi messages to pedals. I have the latest firmware update.
https://www.roland.com/global/support/by...b0ba96671/

With cable all is fine,I have midi signal to the pedals, so the problem is the connection with the Bluetooth.
Reply
#6
A couple of things - check pages 14 and 15 of this if you haven't yet: https://static.roland.com/assets/media/p..._e01_W.pdf

Did you switch your pedal behavior to send MIDI instead of turn pages (that was mentioned in the firmware update notes)? Did you pair your tablet with your keyboard over bluetooth first, then connect using MIDI over bluetooth in MobileSheets? I just want to make sure all of those steps were taken. 

The "Manage Device Connections" is for connecting one device running MobileSheets to another device running MobileSheets so that you can have one load songs/setlists on the other and turn pages. It's used to synchronize page turns and song loading on multiple tablets. That isn't what you want to use for this. 

Thanks,
Mike
Reply
#7
Yes, I did all those things
Reply
#8
If you connect your tablet with a cable to the keyboard and receive MIDI messages from the pedals, but it doesn't work with bluetooth, that definitely limits the scope of the problem. That would seem to imply that something is going wrong with the bluetooth connection, but it's extremely difficult for me to say what that could be. Let's try something completely different:

1) Get this app off the Microsoft Store: https://www.microsoft.com/en-us/p/midibe...verviewtab

2) Download and use loopMIDI to set up a virtual MIDI port: https://www.tobias-erichsen.de/software/loopmidi.html

3) Connect MIDIberry to loopMIDI and also connect MobileSheets to loopMIDI. 

4) Connect MIDIberry to the keyboard

After doing that, send a MIDI message with the keyboard and see if it flows to MIDIberry, then through loopMIDI to MobileSheets. I'm curious if this will work any differently.

Thanks,
Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.