• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
black pages
Can you share that file with mike@zubersoft.com so I can test with it to ensure that my latest fixes prevent any black pages? My only concern is that I discovered that the main cause of black pages would only occur once entering the annotations editor, and then turning pages or zooming, and then exiting. I had some other changes I had implemented previously to also prevent black pages, but I removed those thinking that the issue was only related to the annotations editor. If I see any black pages with your file, I can put those other changes back in if needed.


There is a problem with that idea. The only way for me to get the file to you is to export it from my database as a PDF as I completely modified the original problem file.

What is weird is, I did that PDF export and decided to try and re-import the local MSP exported PDF file back into my database to see if the black screen problem would repeat itself...

...it doesn't.

I also tried importing a smaller PDF file into my database with links & bookmarks via the Companion to see if the problem was related to Acrobat created links or bookmarks and that file exhibits NO black screen when opening.

Therefore, I have a funny feeling the original PDF I imported into MS via the Companion, got corrupted in the transfer process (probably because I got impatient and tried to look at it in the Companion before it finished transferring). It wouldn't be the first time a file I transferred via the Companion got screwed up in the transfer process. In all of those other cases, I just deleted the problem file from my database, re-imported it and all was well.

As an experiment, I tried a transfer of another similarly large (16 MB) PDF file via the Companion and it it also exhibited some weird behavior. I waited until I saw that it had successfully transferred to my database in the "Connection to PC Status Log" but it wouldn't disconnect from the Companion when I clicked DISCONNECT. I don't know if that meant it was still transferring despite what the Status Log read, but I had to close the Companion to get it to disconnect.

When I tried to open it the first time, I got a black screen.

So again I exported the newly transferred file as a PDF via MSP on to the machine running MSP. I deleted the file from my database and re-imported the exported local file back into my database.

When I opened it, just like my earlier experiment, NO black screen.

This leads this totally uninitiated person to conclude it has something to do with the transfer of large files via the Companion either because they are not finished transferring despite giving that indication on the Status Log and as a result the file is getting corrupted.

I tested THAT theory by directly importing the same large file locally via a USB stick in to my database on the machine hosting MSP. When I imported it that way, it opened perfectly.

I hope this helps.
Scherzo - Do you still see the spinning circle when you load the problematic PDF? I have fixed an issue in the Windows 10 version where it won't display an error if the file fails to load, so the circle will just spin indefinitely. With the next update, if the file can't be loaded for any reason, you will see a proper error message now. If you saw a black page with no spinning circle, that would be an entirely different situation.


When the problem was happening, the circle would spin when I first click the file to open it and the screen is black, but the circle spinning stops once the black page is loaded.

If I click or touch the page, the upper & lower tool bars appear like any other normal file, but the rest of the screen is black. Unfortunately I don't remember if I tried advancing pages and if other pages were black too.

If I closed the file and and tried again, it wouldn't happen unless I restarted MobileSheets. Then it would happen on the first attempt to open the file.

I also notice that even the large file (16 MB) I tried as an experiment that DOESN'T have the black screen issue, does lag a bit when I open the file. It displays the same black screen and spinning circle for about a half a second before the file opens normally as opposed to other files in my database which are very small in size and open instantly.

I assume that behavior is normal in MobileSheets with large file sizes?

An update and a d'oh...

Math was never my strong suit and apparently neither is moving decimal points...

The problem PDF file in question wasn't 16 MB's or even 60, it was 600!! The result of someone (not me) scanning a ton of scores as JPEG's and saving them as a PDF.

Using Acrobat I managed to reduce the file size from 600 to 100 MB's. I tried transferring the 100 MB PDF to my MobileSheets database via the Companion and despite being a tad slow, when the "Connection to PC Status Log" said it was done, it was done and I could disconnect by clicking disconnect.

The NEW slimmer & trimmer file opened just fine, albeit microscopically slower than 10 K files with NO black screen.

I hope this unclouded this mystery a bit for you.

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

Users browsing this thread:
1 Guest(s)

  Theme ¬© 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.