• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MIDI implementation questions
#1
Hi all,

I am a recent (yesterday) convert to MobileSheets on Android, having used unrealBook successfully on iPad for about a decade. But I’ve had it with iPads.

Now I am trying to transfer about 100 songs and their MIDI control parameters into MobileSheets. I’ve got the songs in, but I have hit a brick wall with the MIDI.

The hardware is:   
Galaxy Tab 7+ tablet  => USB cable =>  Line6 Helix (guitar, MIDI channel 4)  => MIDI cable => PA echo unit (vocals, MIDI channel 1)    (Both MIDI channels count from 0, i.e. Helix thinks it is channel 5).
 
I have set MobileSheets to control multiple MIDI channels but I am not sure on how to proceed. It seems that each program has its own nomenclature.
 
The Helix midi guide says to send a message like
CC32: 004          (Change setlist, Setlist = 5 (counting from 0))
PC: 011                (Change preset, preset = 11 (presets are listed from 0)
CC69: 000            (Change snapshot, snapshot = 0 (snapshots are listed  from 0)
 
So, three questions:

1.     How do I use the MIDI edit page to enter such a message?

2.     Is there a way to directly enter the hexadecimal codes that I already have for each song?
e.g. this song has a sequence:
   B1 00 01   (To change the bank on my Behringer Virtualizer Pro)
   C1 1F         (To change the preset on the Behringer)
   B4 20 04      (Change setlist on Helix, Setlist = 5)
   C4 0B            (Change preset on Helix, preset = 11  (= 0B in Hex)
It would be great if I could just cut and paste using the companion app

3.     Can I put a separate MIDI string on each page of a song? Several songs have different feels in different sections and previously I have arranged them so that a page turn will change the guitar and vocal effects sounds. That way I only have to push the page turn pedal to accomplish all three changes. 

Any guidance would be appreciated.

Cheers
Simon
Reply
#2
I am definitely watching this thread.  Having Mobilesheets automatically change synth setting when I open a new song is something I should figure out (Casio CTK-7200/Casio PX350/Mobilesheets).
Reply
#3
Hello Simon,

1) You would first long press your song, tap "Edit Song" at the top of the screen to go to the Song Editor, then tap on the MIDI tab, then tap on +. This will bring up the dialog to add a new MIDI command. For the first command, you would select a Command Type of "Control Change" as CC32:004 means control change with number 32 and value 4. So after you cahnge the command type to Control Change, enter 32 in the number field, and then 4 in the value field. Then tap OK. Now tap + again, select Command Type Program Change (PC = Program Change) and enter a value of 11. Then tap OK, then tap + to add a third command, and create a control change with 69 and 0. 

2) You can certainly send hexadecimal codes if you are talking about a system exclusive message. Just change the command type to "System Exclusive" and then enter the hex characters into the Command field. 

3) You would need to use smart buttons for this. Load your song, tap the center of the screen to bring up the song overlay, then tap on the icon at the bottom right that looks like a finger tapping a button. On the Smart Buttons window, tap + to create a new one, use the default action of "Send MIDI Commands", then tap + and add a new MIDI command. Just like the song editor, you would set up the list of MIDI commands to send when the button is tapped in the same way. Once you've entered the commands, tap OK, then tap on the page where you want the button to be placed. Now you can tap that button to send all the MIDI commands.

Let me know if that helps you get started. I'm happy to help answer any other questions.

Mike
Reply
#4
Hi Mike, 

Thanks for your fast response. I'll have a go.   :-)

Cheers
Simon
Reply
#5
(06-14-2021, 05:40 PM)SimonW24 Wrote: Hi Mike, 

Thanks for your fast response. I'll have a go.   :-)

Cheers
Simon

Update: I tried entering MIDI data via the built-in translator and also using the sys-ex system. Both worked - at first. 
Unfortunately, I can send about 3 messages successfully before the Helix becomes unresponsive, and I can't get it to work again. 
If I unplug the cable and reinsert it (and give the tablet permission to use it), then the messages work again, but only ~3 times. 
I have looked at suggestions for sending MIDI from a Samsung Galaxy Tab s7+, and have set USB to default to MIDI, and turned off audio over USB. 
I am connecting the tablet to the Helix directly with a USB-C to USB-B cable. I have seen othe people using a special MIDI adapter, but I don't know if these are old sites. 
Any suggestions?
Cheers
Simon
Reply
#6
Simon,

If you go to Settings->MIDI Settings->Configure MIDI Connections, there is a dropdown that controls which MIDI library is used. I would suggest first switching to the Google MIDI library (which requires selecting the input and output ports to connect to) and see if that behaves better. If it does not, you can also try the high-performance USB MIDI library. Hopefully one of the two will not misbehave with the Helix.

Mike
Reply
#7
Hi Mike,

Thanks again - but no solution, just more symptoms. I tried your suggestions without success, then decided to do a systematic test of the options.
I pulled out the USB cable and reinserted it and got a message something like “Midi device Line 6 Helix has been attached”

Default library selected:
Four songs were selected OK, then the MIDI messages no longer worked. (Reproducing my earlier experiences)
 
I selected Google library:
“Midi device Line 6 Helix has been detached”
 “Line 6 Helix [0]” was displayed on both input and output ports.   (I was puzzled by the zero. Is that saying it's disconnected? The Helix was on channel 5)
Commands didn’t work at all.
I detached and reattached the USB cable. It asked for permission to use audio from the Helix. Accepted.
Didn’t work.
 
I selected High performance Library:
“Midi device Line 6 Helix has been attached”
Now consistently it selects the song correctly but MobileSheets crashes immediately every time. However, if I open MobileSheets and reselect the same song, it doesn’t crash. I guess that the MIDI message isn’t being re-sent.
 
In other news, I tried routing signals via a Kenton MIDI USB Host Mk2, but it wasn’t recognised as a host at all. The tablet warned me I was using a charger with a slow charge rate!

Do these symptoms prompt any ideas?
I am beginning to think that I may have a bad, or wrong USB cable. I will have another coming in a day or two that is specifically an OTG cable from USB C to USB B. Unless you have any other suggestions, I will report back after I try that.

Cheers
Simon
Reply
#8
FWIW, I am going to take another run at Mobilsheets automatically selecting sound sounds (program change) on my synth via Bluetooth midi when i select a song in MS.

I just ordered this https://www.walmart.com/ip/UTB-21-USB-MI.../374544128

....because I have some concerns about running a usb cable from the tablet.

We'll see how it goes

Jeff
Reply
#9
Simon,

I'll be curious to hear if the new cable helps, as it definitely sounds like something is interfering with the connection in some way. I've certainly seen other users in similar situations and a new cable did fix the problems for them. Also, just to verify, what settings have you changed under Settings->MIDI Settings? You didn't enable anything like "MIDI Echo", did you?

Mike
Reply
#10
(06-16-2021, 11:25 PM)jeffn1 Wrote: FWIW, I am going to take another run at Mobilsheets automatically selecting sound sounds (program change) on my synth via Bluetooth midi when i select a song in MS.

I just ordered this https://www.walmart.com/ip/UTB-21-USB-MI.../374544128

....because I have some concerns about running a usb cable from the tablet.

We'll see how it goes

Jeff

Good luck Jeff. I will be interested to hear how you go. 

Simon
Reply
#11
Hi Mike, 

I did briefly try MIDI echo, but that didn't help. It's currently turned off. 

My settings are:
MIDI channel 6
Echo off
Multiple MIDI channels on
Midi device: Generic
MIDI connections: all options tried. 
MIDI actions: none

Simon
Reply
#12
Hi all,
It seems that the problem was with incompatible cabling. I got a MioXC and now it seems to work perfectly.
Cheers
Simon
Reply
#13
The Mio products work really well to resolve these kinds of issues. I'm glad that fixed it for you.

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.