• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Companion connection problems
#1
I'm new to MobileSheets, and I'm trying to get the Companion to connect to my ASUS TF300T. I have downloaded the ASUS suite and installed it on my PC, which is running Windows 7 Pro. It is connected to the internet through the same router my PC is connected to. It's also connected via USB and bluetooth, though I don't think that makes any difference.

What do I need to do?
Reply
#2
Does your PC have a firewall set up (possibly with your anti-virus scanner)? Make sure to disable it. First off, do you get a pop-up when you have MobileSheets Companion running, and you click the sync button the tablet? If so, and the connection fails, does it eventually error out, or does it just hang? Have you tried toggling the wi-fi on your tablet on and off?

I'm going to introduce support for connecting over bluetooth at some point, but until then, I'm going to look into ways to make this connection process easier. Far too many users seem to have issues with it...
Reply
#3
Yes, I do have a firewall - a part of McAfee Total Protection. Okay, I disabled it. No, I'm getting nothing on the tablet. Or, at least, nothing I can see. Is that supposed to be in the notification area? Or a pop-up like you get in Windows?

BTW, I have the firewall is set up so that 192.168.1.0-255, which is what I use on the router, is a trusted network.
Reply
#4
Could you explain how you're trying to connect to the companion? You shouldn't expect to see anything on the tablet until after it's connected (by which time it will be obvious).

The process is as follows:
1. You should have Mobilesheets open on the tablet, and the Companion app open on the pc.
2. On the tablet you click the circle of arrows (towards the top right) which is the connection/sync icon.
3. On the companion app a window should pop up saying that a device is trying to connect.

Chris
Reply
#5
Okay, that was problem one. Didn't know how to activate the connection. I can connect, but I have to disable the firewall. It seems that I need to tell the firewall that it's an exception. What port does the Companion use to talk to the tablet?

Meanwhile...

I found that if I enable all ports, I can connect... Sometimes. And if it does connect, it disconnects after a few seconds. Just now, it gave me this error:

Error encountered while sending data to tablet:
System.Net.Sockets.SocketException (0x80004005): An existing connection was forcibly closed by the remote host
at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size,
SocketFlags socketFlags)
at MobileSheetsCompanionSocketConnector.MySendSong(Object arts).
Reconnect the tablet and try again.

Thanks, guys. This looks like a great thing if I can just get it working.


(06-23-2012, 06:47 PM)cdawe55 Wrote: Could you explain how you're trying to connect to the companion? You shouldn't expect to see anything on the tablet until after it's connected (by which time it will be obvious).

The process is as follows:
1. You should have Mobilesheets open on the tablet, and the Companion app open on the pc.
2. On the tablet you click the circle of arrows (towards the top right) which is the connection/sync icon.
3. On the companion app a window should pop up saying that a device is trying to connect.

Chris
Reply
#6
The initial broadcast is sent on 8888, and received on 9999. The broadcast is used so that a TCP/IP connection can be made directly between the PC and tablet after the IP addresses are shared. I'm currently using two TCP/IP connections (one each way for simplicity) using ports 16568 and 16569. At some point I may consolidate this to one connection. All of these ports were chosen arbitrarily. If anyone thinks these are problematic, let me know.
Reply
#7
Great! I'm connecting now. I added ports 16568 and 16569 to the list of ports that are allowed by my firewall, and that did the trick.

I looked those two ports up on Wikipedia, and they're not commonly used for anything, so I would say that it's a good choice.

I suggest that you might want to add to the troubleshooting information in the manual that talks about trouble with connections, that these ports need to be added to the exception list of any firewall that the user is running.

Thanks for your help.
Reply
#8
Glad I could help. I'll definitely add that to the manual - thanks for the suggestion. The manual is way overdue for updates...
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.