• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pitch black page...
I was just about to sit down and write a very grateful "Thank you" post for the new update, when disaster (ie, black page) struck again! But this time it was slightly different than before: The black page was now accompanied by an error message (either because it was actually a different issue, or because Android 4.4.2 gives more helpful information than Android 5 (remember, I recently downgraded). If this is indeed the same issue, it seems the problem may be something completely different than what we've hitherto believed.
Anyway, what happened was: I opened the song, turned a few pages, and suddenly got a black page with the message: "File not found: [Location such and such].pdf". I was too perplexed to note exactly what file path was mentioned, but as far as I could see, the file which could not be found was the file which I was already playing from, and which had already successfully displayed 4 or 5 pages. How strange! When I went back to the library screen and opened the same song again, everything was back to normal.
May this whole problem have something to do with wrong path names or duplicate files? How could MSP open and display the first pages of a file, and then complain that the file in question doesn't exist? I have actually noticed strange things happening to my path names lately, but wanting to get the black page issue fixed first, I haven't mentioned anything about it yet. But may these things perhaps be related?

I'll try to describe what I've experienced lately:

I have always kept the "Let msp manage my files" option unchecked, prefering to manage my own files. I have had the pdf files stored in a folder called "Noter" (ie, "Sheet music" in Norwegian) on the tablet itself, with subdirectories "Beethoven", "Mozart" and so on. I've also organized my audio files in a similar way, but on the external sd card.

During Easter vacation, desperately trying to get rid of the black page problem, I made a backup .msp file of my library (including settings, but not including audio files), uninstalled MSP and reinstalled. I didn't delete any files, but restored the library from the .msp file to get my library back the way it was (selecting to keep original folder layout). At first I noticed nothing special, but then, when I tried playing an associated audio file, nothing started playing. Examining this closer, I noticed that the path under the "Audio" tab had mysteriously changed after the backup - from "/storage/extSdCard/Musikk/Schubert/SchubertTrio1.mp3" to "/storage/emulated/0/Android/data/com.zubersoft.mobilesheetspro/files/SchubertTrio1.mp3". This path and file didn't exist, which explains why no file started playing. I had to manually edit the path (for this and all other audio files) back to the correct one.
What I didn't notice then, but have realized later, is that all the pdf files were probably also duplicated in the /storage/emulated/0---etc folder after the backup, ie as if MSP were set to organize my files (which it wasn't).

Only now, after downgrading and wiping all data from the tablet, did this became apparent to me, as my original folder "Noter" was almost empty after restoring my backup, and most of my files ended up in the /storage/emulated/0---etc folder. I still don't understand why, as I've always been very careful to uncheck every box asking if MSP should organize my files. Note also that it was almost empty, not completely. Some of the files still ended up in my own "Noter" folder (!)

Anyway, I guess something must have gone wrong during a backup, either now or sometime in the past, making MSP look for my files in two different locations at the same time (?), both mine and its own folder. Could this in any way explain what I'm experiencing, and the mysterious error message I received today? Maybe even the black pages I've seen in the past?
The error you saw is something I display, so it would be the same if the OS was 4.4.2 or 5. Based on your description, this may have been the same kind of problem. If your device was running critically low on memory, I may have tried to force resources to be cleared. I'll have to rework some of that code if that's the case, but I would be very curious to see how much RAM was available on your device when this happened. If you had a large amount of background apps or tasks running (or even just one or two that use a lot of RAM like MobileSheetsPro does), this may have contributed to the problem.

As for the other issues you described, there is a little bit of a problem when using an external SD card with Android 4.4 or higher - MS Pro will not be able to write to it. That means you cannot restore a backup to an external SD card unless you use the application data directory for MS Pro: <external SD card path>/Android/data/com.zubersoft.mobilesheetspro/files. When MobileSheetsPro runs into this situation, it will revert back to the internal SD card so that the backup can proceed. Other posts have been made about this to provide better options for handling this situation and to provide more information to the user. As a side note, I'm not sure if you selected "Original File Locations" as the destination on the restore dialog. If you did not, then MobileSheetsPro wouldn't have even tried to write to the external SD card.

I think your case, if you want to manage your own files, you would be better off just backing up the MobileSheetsPro database file yourself, and backing up your external SD card files when needed. If I can overcome the external SD card limitations for Android 5.0, then this will all be supported through backup/restore again. Unfortunately, as mentioned in other posts, I have a fair amount of work to do there as it turned out to be very difficult.

Thank you, I understand. So the "File not found" error is actually expected when the device is running low on memory? I can't really see how this could be the case for me, thoguh, as I had no other background apps running at the time (except for Chrome, and maybe Acrobat reader). I haven't really used any apps other than MSP after downgrading.

I'm pretty sure I unchecked "manage my files" when importing the .msp file, but of course, I may have forgotten during an earlier backup, so that the duplicate files have been there for some time without me noticing.. But I'm confident I have always unchecked "backup audio", as I was aware of the problems with the external SD card, and also not wanting the backup file to be unnecessarily large - so I don't see why the backup would even try to write anything to the external card.
My theory is that the device was running critically low on memory and requested that my app free resources or it would kill every background task and app (in that scenario, I am still freeing resources that could potentially be in use). I'm going to rework this code for the next update to be a little safer. Having said that, if your device had plenty of memory, then I have no idea how this could have happened, especially if the song loads fine every other time you try it.

"Manage my Files" doesn't actually change the way backup/restore works. A backup file will still contain every song file in the library and the database file. So even if you don't include audio files, when you restore that backup file, it's going to try to extract all of the song files to the destination you've selected. That's why I was suggesting that, if you don't need the files to be backed up, it's much more efficient to just back up the database file yourself, as that's all you really care about or need. If you check the "Expose Database" setting, then you can copy the database file from the storage location to any place you want. Likewise, to restore your library, you can just drop a new database file in and reload the app. As long as you've left your files on the same place on the external SD card, everything will work fine. The one piece not really handled by this would be the application settings though... I don't really think there is a workaround for that at the moment.

Back to this thread - but this time only to thank you, as I believe this problem is gone after all. I have had more than 30 performances the past two weeks, and played probably several thousand pages, but haven't had a single black page!

Thinking the matter through, I realized I might actually have a quite memory consuming app in the background (which I had closed, but which was probably still eating up some memory). Restarting the tablet (and, by the way, going back to Android 5, as the os version didn't seem to have anything to do with this), and then avoiding the app in question alltogether, the black pages seem now to be gone once and for all.

So thank you so much Mike, I'm finally sleeping well at night again! :-)
Would you mind posting the app in question? There may be others of a similar nature we could avoid/consider.
Dell Latitude 13.5" 2-in-1 Ubuntu/Win 11
Samsung Note Pro SM-P900 12.2 Android 5.0.2
Samsung S7+, Android 12
Thanks for the update - I feel a lot better knowing this problem is addressed now.
Skip: It was a game actually, The Bard's Tale. But I don't believe there was anything wrong with that game per se, only that Android apps generally stay in memory even after you close them (unless you also close it from the app manager) - and this was probably a quite memory consuming one. The last Msp update was probably what solved the issue, but I'll also try to avoid other heavy apps on this tablet in the future, just to feel safe...
Thanks Steinway, the point on closing via the manager is a good one, at least for me.
Dell Latitude 13.5" 2-in-1 Ubuntu/Win 11
Samsung Note Pro SM-P900 12.2 Android 5.0.2
Samsung S7+, Android 12
I'm so sorry! Really! To bring back this thread once again...
But alas.. I just had another black page! And I have deliberately refrained from using any other app (apart from Adobe reader) the last weeks, just to make sure there could be no memory conflicts.
After successfully turning through several thousand pages, I was so sure this problem was gone forever..
The only thing I did differently today, which I believe I haven't done for a while, was to play an associated audio file while viewing the score. And turning the pages while the audio file was playing. Could the fact that the audio file was playing in any way have caused a memory conflict, with a resulting black page..?
...and another thought - though probably quite far-fetched.. A couple of pages before the black page appeared, I noticed the page suddenly resize itself slightly even though I was nowhere near with my fingers. I then realized my headphone cable was touching the screen, and wondered if there could be any kind of intereference from this cable which made the tablet believe I was trying to pinch zoom. Is there any chance this could be related to the black pages that appear? I certainly haven't used headphones every time I've seen the black page, but I realize I may have done so quite often - either connected to the tablet (listening to associated audio files) or connected to the piano while practicing. At other times, when the black page have appeared without me using headphones, there may have been a humidity control system on the grand piano which may have caused some kind of intereference with the tablet. Of course, I'm not even sure this is possible or in any way could explain what I'm seeing, I'm just clutching at straws, desperate to find an explanation...
I'm sorry to say this has happened to me a few times as well, in the last weeks.
I'm in "heavy practice" mode at the moment, using MsPro two to three hours
every day.

As you can see, annotations are displayed, but no music.

Possible relevant settings:

- Allow Zoom Out Past 100%: Off
- Disable Page Turn Animation: On
- Always Show The Title Bar: On
- Show Preview During Page Seek: On
- Overlay Toggle Mode: Single Tap
- Render Preference: Quality
- Dim Navigation Bar: On
- Full Screen Mode: On

I'm including the Overlay Toggle Mode since I've noticed this never happens
when I use a pedal to turn pages. Would it be possible to tap somewhere on
the screen that confuses a page turn with an overlay tap??

BTW.: I'm also using NotePro with 5.02

Attached Files Thumbnail(s)
Using Samsung Note Pro (SM-P900) with Android 5.0.2
Ketil's screenshot shows exactly what I'm seeing too - completely black page, but annotations are shown if there are any. So this is definitely the same problem.
My settings are almost the same as his (even language, which I guess we have both set to Norwegian). Except: I have enabled page turn animations, and I use a diagonal swipe to toggle the overlay. Also note that I have experienced this while using pedals (but only once, as far as I can remember). It usually happens when touching the screen to turn the page, which is why I almost only see this while practicing (I don't use the pedals when practicing).
Many posts in a row - but I just felt the need to clarify a small point: as I said, I have experienced this once while using pedals, otherwise I agree with Ketil that this only happens when touching the screen to turn. But, thinking back to the occasion when this did happen with pedals (which I remember very clearly, being the only time it has happened during a performance) - I realize I did actually touch the screen once before using the pedals. The said performance was an audition where I accompanied a trumpet player - and at such occasions I always skip the first page of the piano/orchestra introduction. So I realize I must have touched the screen to turn to page 2, where I started playing, and then turned with the pedals from there on. Subsequently, page 4 turned out black. So whatever caused the black page to appear may very well have happened when I touched the screen at the first page. So to be precise: I have never had a black page when ONLY using pedals to turn, without ever touching the screen at all.
Were you both using the single page display mode? I'm trying to run through some tests right now with the same settings on my Note Pro and I want to make sure everything is the same.

Ketil - Were you testing with setlists or individual songs?


Users browsing this thread:
7 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.