• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sync Failing Between Two Kindle Fires
Since January 2021 I've been successfully syncing MobileSheets Pro between two Kindle Fire HD 10.1 (9th Gen) tablets. However, that function quit working in mid-November. I had been doing Two-way sync, using data from the song that was modified last, connecting using Bluetooth. 
     Now when I do that, the timestamped sequence is: 

  1. the Server says the database file was successfully sent, 
  2. the Client says it was successfully received and written to /storage/emulated/0/Android/data/com.zubersoft.mobilesheetspro/cache/temp_mobilesheets.db, 
  3. the Client said it successfully sent its database file, 
  4. and the Server says it was successfully received and written, 
  5. then the last thing the Server says is Initializing database. 
     However, when I check the Client, none of the new songs or setlists are there. 

     Also, I believe the app used to automatically close the Device Sync Activity screen when completed, and return back to the previous app screen, but now they're not doing that either. In fact, now when I pick the Previous Screen button on the Server, often a pop-up says "A merge is currently in process. Are you sure you want to cancel the merge: Some songs may not load correctly if you proceed." I usually select Cancel, wait, and try again until it goes to the previous screen without the pop-up, but after 10-15 minutes I pick OK instead. All the content (songs, setlists, collections) on the Server seem to be fine.
     To try to figure out what's wrong I decided to start changing sync options. Once, when I changed the Sync Type to "Update Client" on the Server tablet, I got something like this message on the Client: "Received database version 00 but expected 58. MobileSheetsPro must be the same version on each device. Ending sync." However, that only happened once. Now, even when using those same settings, the Status messages look the same as when doing the two-way sync!
     I tried the sync via Wi-Fi instead of Bluetooth, but the Status messages and Client not updated symptoms still look the same... they just happen faster.
     Both tablets were updated to the latest Fire OS about the time the symptoms appeared. There have also been MobileSheets Pro updates during this time, so I've checked to see both are the latest (in case that was a problem). One of the recent updates (think it was Mobilesheets, maybe Fire) asked me some questions about permissions including Bluetooth, and I wonder if I answered that wrong.
     Another odd thing is that the Client used to see "Maverick" as the Server's name for the Connected Device when it was working. When I noticed it wasn't working, the Client was connected to "Lakeview's 2nd Fire" instead. So I wonder if the Fire update changed that to match my Amazon account name for the device? I found where that is set in Fire Bluetooth Settings, and named the Client bluetooth "Lakeview's Fire". I've also noticed that the Server says on the Device Sync Activity page that the Connected Device is "Lakeview's 2nd Fire", which looks like the Server is connected to itself?! Is there a limit on how many characters Bluetooth looks for in a name, and these are too close to the same and confusing the Server? 
     Another symptom that showed up is a pop-up after clicking Create Server, that asks permission to make the Server tablet visible by Bluetooth for 120 seconds. It never used to do that before when things were working well. 
     When I've tried to Pair New Devices in Fire Bluetooth Settings, they don't seem to see each other. The Available devices list just has the circling searching status icon. So in the Fire Settings I did a Network Settings Reset (including Wi-Fi and Bluetooth). I renamed the Server Bluetooth "device name" to Maverick, and the Client to Lakeview. Now I could at least pair them in Bluetooth. However, now when I try to Sync, the Client still says it's connected to the Server (but now named Maverick), has the same Status messages, and doesn't get the new information, and the Server also misbehaves in the same way (but now it says it's connected to Maverick, still itself, instead of to Lakeview the other tablet).
     So I've tried everything I could think of without diving into MobileSheets folder structure to check out files there, or trying to reinstall the app (I really don't want to lose my song mark-ups, setlists and collections). I'm sorry if some of my troubleshooting has actually made my situation worse.
     Any guidance on next steps to try? It would be greatly appreciated.
Is there a reason you need to sync the library over bluetooth versus WiFi? WiFi is considerably faster and less prone to connection errors. Can you try synchronizing over WiFi to see if that works better for you? I just would like to know if that at least works properly between your devices.

(12-10-2021, 06:56 PM)Zubersoft Wrote: Is there a reason you need to sync the library over bluetooth versus WiFi? WiFi is considerably faster and less prone to connection errors. Can you try synchronizing over WiFi to see if that works better for you? I just would like to know if that at least works properly between your devices.


There is no reason I need to sync over bluetooth. I'm always using WiFi in the venues where I do the syncing. I think bluetooth must have been the default when I first tried syncing, and I never tried anything else until I started having these problems. However, the symptoms are still the same with both connection types, except as we've agreed, WiFi is faster. The sync has only ever taken 5-10 seconds with bluetooth though.

I'd like to look into this further, but due to the fact that I don't see any issues with my own test libraries, it would be great if you can create a library backup file under Settings->Backup and Restore->Backup Library, upload that to the cloud (Dropbox/Google Drive/OneDrive) then share a link with mike@zubersoft.com. I will then restore your library on two devices, make a small change, sync them and see if I run into any of the issues you have listed. If you haven't done so, it might be a good idea to try restoring the library backup file from one device on the other, then trying to make a change and sync over WiFi to see if that helps at all.


Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.