• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot Print
I can't seem to print either via the "Share" feature or the "print" feature. When try to print via the "Share" feature and select my program (PrinterShare) it just shows up as a blank page in the preview window and if I select print my printer prints a blank page. 

When I us the "Print" feature and I hit the "print" button nothing happens. I'm using a Samsung Galaxy Mega 6.3

Any reason for it not printing?
I'm going to need a little more information. What type of file are you trying to print (PDF/png/jpg/txt), what version of the OS is your tablet currently running and what is the brand of the tablet? When you use the print feature, are you also utilizing PrinterShare?

I'm trying to print pdfs.  My Samsung Mega is on 4.2.  I also tried printing without success on my Samsung Tab Pro 8.4. (Android 4.4.4)
Printershare appears to have some major limitations. When you use the "Share Files" feature, my application requests any other application on the tablet that can accept files to be sent. Printershare actually has four different applications that can all respond to requests to send files, but of those four, three of them require that only one file be included in the send request. That's why you only see one "Printershare" option that shows up in the list. The one printershare option that shows up in the list only supports image files! So if you happen to try to print a song using image files, you would find that it actually works like you would expect.

I don't want to limit my application to only sharing one file at a time, because if an application says it can accept multiple files to be sent, it should handle it correctly. Having said that, I wanted to make sure you could continue using the printershare application, so what I've done is I've added extra code that checks to see what application has been selected, and if it's printershare (and a song with only one PDF has been selected), I modify my share request to only include one PDF and to launch the correct PDF Printershare application (it's actually called ActivityPrintPDF, whereas the one you see now is called ActivityPrintPictures). So, you can continue using it if you like, but you can only print one PDF at a time. You may have to download something in PrinterShare to handle PDFs if you haven't done so already (I did the first time I opened one)

As far as the actual print option in the app, devices below 4.4 are forced to use Google Cloud printing, as there is no printing capability on them. Devices running 4.4 actually have a way to use print services (such as the PrinterShare print service). I tested the PrinterShare print service on my Nexus 10, and it worked perfectly. I tested the Google Cloud printing on my ASUS TF101 (running android 4.0.3) and also didn't have any issues. When you tried to print on your Samsung Mega 4.2, did it try to load a web browser for Google Cloud Printing? Or did absolutely nothing happen?


Awesome- you fixed the PrinterShare issue- I can now print! As far as the native print function on my Samsung Mega running on Android 4.2- it takes me to a print screen but when I hit the print button nothing happens. The weird thing is that on my Samsung Tab4 which runs on 4.4 it does the same thing.

Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.