• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't expose mobilsheets.db anymore
As above.

I wanted to transfer the database to my new Surface Pro so I looked in the usual directory 


where it has always been before and I have often copied and synced from (though not in the past 4 to 6 weeks).

mobilesheets.db is gone from there. I can't find it anywhere else though MSP still loads the database fine upon start.

In the dir are still mobilesheets_internal_backup.db, mobilesheetsbackup.db and mobilesheets.db.backup albeit with a file date of 16/12/17 so MSP seems not to have used them since that date.

I tried unticking and ticking again the expose database box to no avail.

What's happening here? My Android tablet is a Sony Xperia Z4 with Android 7.1.1
What's your setting of Storage - Set the MobileSheets Storage Location (Speicher - MobileSheets-Verzeichnis einstellen)?
first language: German
Acer A1-830, Android 4.4.2 - HP x2 210 G2 Detachable, Win 10 22H2 - Huawei Media Pad T5, Android 8.0 - Boox Tab Ultra C, Android 11
www.moonlightcrisis.de - www.basdjo.de - www.frankenbaend.de

It's set to


as I wrote above.

Also I used search programs for mobilesheets.db to find it, but it can't be found anywhere in the accessible directories (my device is not rooted).


OK, I got it back. Thanks itsme, you got me on the right track. I changed the path to


and exposed again. 

Also I remembered I moved all movable apps to the external SD card and MSP was one of these. So I moved it back to internal memory.

One of those two things solved it, so now I'm relieved I can backup and transfer my db again.
Sorry I wasn't able to provide assistance. I'm glad you got it all working again. It was probably moving MobileSheetsPro back to the internal storage that fixed it. It does not respond well to being moved to removable SD cards.


Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.