• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MSP not updating, doesn't appear in Google Play
I feel stupid. I'm generally pretty tech savvy but I run MSP on an old Samsung tablet (SPH-P500, Android 4.1.2) and it's essentially all I do or have ever done on a tablet.

I've used MSP for a while and the only issue I've had is back when the Dropbox import stopped working (because, as I recall, of some change made on the Dropbox side). At the time, it didn't seem like it was a solvable problem, but the notes on recent updates seem to suggest that it works again. It's a real pain to add new stuff now.

It doesn't work for me. So I looked up my version number: 1.2.3.

Aha, I think! It must not update automagically - I need to update! So I go into Google Play and Mobilesheets doesn't show up as an installed app - so I don't know how to update it. (It's not the only thing missing. Flickr, for example is also not there.)

Am I not going about this right? Am I missing something obvious? Is the age of this tablet an issue?

Any help is much appreciated.
I found a similar query from June 11 (searching "version") and tried a couple of things from there without success.

Looked to make sure Google Play had my standard email address. It did and I've used it for many years. I don't know how to check what MobileSheets thinks my email is. I do have a separate email I use when making Paypal purchases - could that be the issue? (Don't recall how I paid for Mobilesheets.)

I cleared the data from the Google Play Store and Google Play Services and rebooted. No change from that process.
Can you send an email to mike@zubersoft.com with the email address you think you used on Google Play to make the purchase? I can investigate things in the Google Play developer console.

Update, after emailing Mike: So it was the email issue. See, "my" tablet was actually my son's but he had stopped using it and I needed something to try out Mobilesheets. So I  adopted/requisitioned/stole the tablet and bought MSP before I realized that I needed to change the Google account from my son's to mine. I switched the account back, updated the app, and switched back to my account and we're good to go.

Many thanks, Mike!
Try contacting the developer team via email with proper details of your purchase, as this is the strange case for me at least.
With Regards,
Xovo Larjem

Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.